Beosystem 3 screen out to Hdmi

Tagged: 

Viewing 20 posts - 1 through 20 (of 31 total)
  • Author
    Posts
  • #19828
    emabonacchi
    BRONZE Member

      Hello everybody and scuse me for my bad english.

      I am trying to use a Beosystem3 “dvi screen out” going into an hdmi source of a Philips 43” television. The result seems ok, but this is unreliable because every minute or two, signal is lost, screen is black and then, after about one second, signal is ok again.

       

      I have changed  Hdmi cable, but nothing changes. I suspect a “resolution problem” because with other televisions, i have no problem.

       

      Can you suggest some kind of settings i can try?

       

       

       

       

      #19829
      emabonacchi
      BRONZE Member

        This job i am doing, i am doing for upgrading my old and loved Beovision5. It is a very hard job.

        Attachments:
        You must be logged in to view attached files.
        #19831
        emabonacchi
        BRONZE Member

          All seems to be ok. A new decoder, a new controller for bluetooth Ps4 command, a new interface for ethernet control integrated in my domotic system and a new life for my old Beovision5.

          All controlled from the original Beo4 remote via the original receiver on the upper side of Beovision5.

          But only last problem destroy all my job. It’s impossible to watch tv when every minutes or two screen signal is lost………. And i really don’t know how to solve this.

           

           

           

           

          • This reply was modified 11 months, 2 weeks ago by emabonacchi.
          • This reply was modified 11 months, 2 weeks ago by emabonacchi.
          Attachments:
          You must be logged in to view attached files.
          #19835
          emabonacchi
          BRONZE Member

            Even the rear side of my old Beovision5 i have fine cutted and modifyed with my hands in order to have a nice black door bordered in alluminium. Over that door, i can easily access at the Beosystem3 connections and at the new Hard disk in wich i have stored all my photoes and my favoutite films.

            It was a real hard job, and i am proud about this.

             

             

             

            Attachments:
            You must be logged in to view attached files.
            #19840
            Guy
            Moderator
              • Warwickshire, UK

              Great project but a frustrating problem!

              I had a similar problem with DVI but in my case I was trying to feed an Apple TV (hdmi) into a BC6-26 DVI input – the picture would ‘blink’ every few minutes.

              One thing you could try (although it didn’t work in my setup) is a ‘EDID Emulator’.  I don’t know or understand much about them so you’d have to do your own research, but they are used to solve display incompatibilities in many applications and may be worth a try if you have exhausted other options.

              Perhaps others have better knowledge of the use of BS3 with alternative (non-B&O) panels and can help further.

              Good luck – please let us know how you get on.

              #19879
              emabonacchi
              BRONZE Member

                Many thanks for your reply! I will study about what “EDID Emulator” is and i will give a try about.

                #19959
                jvezina
                FOUNDER Member

                   

                  Could you try the following:

                  Go to the Beosystem 3 customer service menu (the one accessible by the red arrow in the Beo  4: MENU , then move the cursor to Options, then red arrow and GO) , then to screen configuration.  Set the screen type to generic and output resolution to 1920X1080. Try it first this way. If the synchronization is not correct, change the framelock setting.

                  When I repaired my Beovision 7 (which has a Beosystem 3 inside), I was able to check the video engine by connecting a computer screen to it with the second DVI output and it worked fine for an indefinite period of time. But the output resolution must be forced to 1920X1080.

                  So first check the screen settings in the menus before ordering an EDID emulator.

                  Good luck,

                  Jean

                   

                  #20014
                  Stoobie
                  BRONZE Member

                    If you do experiment with these settings, take photos of the current settings so you can restore them if you mess anything up.

                    Stoobie

                    #29136
                    emabonacchi
                    BRONZE Member

                      Hello and thanks for your reply. I am doing many and many and many trying from months, buto the problem is not solved. It seems i am not able to find the menu tou suggested. In “Options” i press “red arrow” and go, or “0 0 go”, but i really can not find the “screen configuration”. However, after many and many try, i can tell “EDID emulator” is not the solution. And i can tell the problem source seems to be “Playstation 4” connected to “Dvd source”. U did a “giant work” and i am very frustrating because this seems to be a very stupid setting problem able to destroy all mi job……

                      #29143
                      Ravsted
                      BRONZE Member

                        I have had the same issue with a Philips TV connected to a Playstation 4.

                        It had no issues when connected to other HDMI sources such as a Raspberry Pi and/or Blueray Player.

                        I resolved the issue by adding an HDMI splitter between PS4 and TV. It must have fixed handshake or HDCP issue.

                        Like this one:

                        https://www.ebay.com/itm/275939326577?mkcid=16&mkevt=1&mkrid=711-127632-2357-0&ssspo=BpxOZUXaT–&sssrc=4429486&ssuid=0tiQ_XyiTEy&var=&widget_ver=artemis&media=COPY

                        • This reply was modified 2 months, 2 weeks ago by Ravsted.
                        #29148
                        Tignum
                        BRONZE Member
                          • Netherlands

                          Hello and thanks for your reply. I am doing many and many and many trying from months, buto the problem is not solved. It seems i am not able to find the menu tou suggested. In “Options” i press “red arrow” and go, or “0 0 go”, but i really can not find the “screen configuration”. However, after many and many try, i can tell “EDID emulator” is not the solution. And i can tell the problem source seems to be “Playstation 4” connected to “Dvd source”. U did a “giant work” and i am very frustrating because this seems to be a very stupid setting problem able to destroy all mi job……

                          Hi emabonacchi, this is the text from the BS3 service manual:customer service menu

                          It is important that you only place the ‘cursor’ on ‘OPTION’. Don’t press go yet.  ‘OPTION’ only needs to be highlighted, then press the red button and GO. Hope this helps. I will try on my BS3 to reconfirm.

                          Regards, Johan

                          • This reply was modified 2 months, 2 weeks ago by Tignum.
                          #29149
                          Tignum
                          BRONZE Member
                            • Netherlands

                            Just tried myself and could not yet find a way to configure to 1920×1080. Will seek some more.

                            #29150
                            Tignum
                            BRONZE Member
                              • Netherlands

                              Also have been checking the Service Menu:

                              service menu

                              But did not find it there either. Could it be because we don’t have a B&O screen connected?

                              Sorry that I cannot help you any further! Johan

                              • This reply was modified 2 months, 2 weeks ago by Tignum.
                              #29171
                              emabonacchi
                              BRONZE Member

                                I think i have foud the menu you are talking about in “Connection” then “Display 1 output”.

                                It seems a very risky menu….. i suspect a wrong configuration make all the system unusable and i am afraid about this.

                                #29172
                                emabonacchi
                                BRONZE Member

                                  Really?????

                                   

                                  Well, i am using as “Display out” just a “Philips Tv”!!….. so i think maybe the problem is into this Tv!

                                   

                                  All my sources (Decoder and Playstation) go into “Beovision 3” and then go out into “Philips Tv” via “Display out 1”. The strange thing is that source “Decoder” seems not to have this problem while the source “Playstation” have this problem.

                                   

                                   

                                  #29177
                                  Ravsted
                                  BRONZE Member

                                    Well, as said the HDMI splitter fixed it for me. Many of these cheep splitters are known to remove the HDCP (copy protection).

                                    You could try to disable HDCP in the Playstation Settings.

                                    It will obviously prevent you from seeing some content but it could conclude that the problem is indeed HDCP / HDMI handshake related.

                                    #29178
                                    Tignum
                                    BRONZE Member
                                      • Netherlands

                                      Hi emabonacchi,

                                      jvezina suggested in his post to set the screen to ‘generic’. Will that open the possibility to choose 1920 x 1020? Be careful indeed. Good idea to take photographs of the screen!

                                      Regards, Johan

                                      #30440
                                      emabonacchi
                                      BRONZE Member

                                        Many and many try i have done but no success, and i am veru tired about…..

                                        I am thinking about a “reverse” solution. What do you think about using “Beosystem3” only for the audio?…..

                                         

                                        How do you think i could connect the system in this way? I can press the “Sat” button (or any other) in B&o4, so Tv turns on and Beosystem turns on. And then?……

                                        Beosystem3 with surround system, gives great great sound even if the sources is only stereo…… i want to be sure it is not lost!. And how can i connect Dvd reader (Playstation) as to have this able to offer 5.1 audio?…..

                                        I am very confused, but maybe this can be a way to walk…… I want to do a nice work but it is not easy and so, any help is appreciated.

                                        Scuse me for my bad english.

                                        #30445
                                        emabonacchi
                                        BRONZE Member

                                          In the “Beosystem3”, i can see the phone-jack out. Then, i can see “Video in” “L-in” “R-in” “Spdif” and “Ctrl”. Then again another set of “Svideo” and “Video in” “L-in” “R-in” “Spdif” and “Ctrl”.

                                          What are these able to do? I think they are inputs, i am in wrong? How do they works?

                                          #30446
                                          emabonacchi
                                          BRONZE Member

                                            Do you think if i connect a Playstation to the Hdmi in into the Tv and then from the Tv a “Toslink” cable goes into Beosystem3 i can hear a 5.1 audio? If “yes”, can you suggest me something about making it working?

                                          Viewing 20 posts - 1 through 20 (of 31 total)
                                          • You must be logged in to reply to this topic.