Securing glass panels – Beocenter 9300

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoCenter Securing glass panels – Beocenter 9300

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #44165
    stotty1111
    GOLD Member
      • Topics Started 15
      • Total Posts 73

      Brilliant, thanks both, the renovation can now begin!!

      #44166
      Tignum
      GOLD Member
        • Netherlands
        • Topics Started 8
        • Total Posts 367

        Hi stotty, I used 3M 4910F, VHB™ Clear Foam Tape, 6mm x 33m, (about 1mm) Thick that you could consider to use. It has good bonding indeed, but feels a bit less permanent than glues. I used it on a BeoMaster 4500. In the old forums there are some more threads on this: https://archivedforum2.beoworld.org/forums/p/43948/319119.aspx#319119. Be careful with the thickness
        I used methylated spirit that dissolved the original tape but left the paint on.
        Best of luck. Johan

        #44162
        stotty1111
        GOLD Member
          • Topics Started 15
          • Total Posts 73

          Hi all

          Looking for advice / suggestions re securing the glass panels into their cradles on my BC 9300.

          In the past have used double sided scotch tape which seems to degrade in sunlight allowing the panels to move sideways, its not difficult to replace the scotch, but am just looking for other suggestions, I had thought about a thin smeer of contact adhesive but i can foresee future problems!

          And one last question, the outfit that supply belts / bands for the ouverture range, do they do the same for BC 9300? I have lost their email address, hence my question!

          Thanks in advance

          Tony S

          #44163
          Guy
          Moderator
            • Warwickshire, UK
            • Topics Started 14
            • Total Posts 1,260

            I have fixed the glass panels on two BC9500s using super glue gel, with no problems after approx 10 years.  Edit: I meant to add that I didn’t remove the old tape; just applied the gel over the top.

            And you can get the new belts etc from Beoparts. https://www.beoparts-shop.com/product-category/beocenter/beocenter-9300/

            #44164
            Foxtrott
            GOLD Member
              • Topics Started 1
              • Total Posts 61

              Hi Tony

              When the glass panels on my BC9500 came loose afew years ago, I used a black coloured glue to reattach the parts to the panel. It was glue suitable for glass surface, but I don’t remember where I got it.
              The process of removing the residues of the old tape from the plastic frame parts was a bit of pain in the **** but worth the effort. Just be very very very carefull when cleaning the backside of the glass panel as the black coating/paint used comes off very easy when you touch is with anything harder than a feather or cotton wool and the circuits parts for the touch areas should not be touched in any way.

              As for belts for any kind of B&O equipment, I would always recommend “Beoparts” and you can find the belts for the BC9300 in the shop: Link to Beoparts Shop

              Cheers
              Foxtrott

              #44167
              stotty1111
              GOLD Member
                • Topics Started 15
                • Total Posts 73

                Ok, bought the belts, opened up the beast, strangely the tape  belt drive, the long/wide one was perished broken, no idea why! So has anyone out there got a sketch /picture of the way the belt is mounted before I start backside scratching etc?

                Have cleaned the scotch off the glass panels, used IPA without probs!

                Thanks in advance!

                The Finisterian

                #44168
                Guy
                Moderator
                  • Warwickshire, UK
                  • Topics Started 14
                  • Total Posts 1,260

                  Ok, bought the belts, opened up the beast, strangely the tape  belt drive, the long/wide one was perished broken, no idea why! So has anyone out there got a sketch /picture of the way the belt is mounted before I start backside scratching etc?

                  If you bought it from Beoparts they usually come with instructions.

                  #44169
                  stotty1111
                  GOLD Member
                    • Topics Started 15
                    • Total Posts 73

                    No , nothing in the package, however, found a youtube piece which is longwinded but the guy got there in the end, so, tomorrow’s work now sorted!

                    I will mail beoparts later to see if they have an instruction sheet, or even a link to one.

                    #44170
                    stotty1111
                    GOLD Member
                      • Topics Started 15
                      • Total Posts 73

                      Ok, new belts fitted, and, it works, well, there’s a minor victory!!!

                      Now to clean up the case and reconstruct etc!

                      #44171
                      Guy
                      Moderator
                        • Warwickshire, UK
                        • Topics Started 14
                        • Total Posts 1,260

                        Ok, new belts fitted, and, it works, well, there’s a minor victory!!!

                        Great news – I think I know the YouTube video that you followed and agree about the longwinded-ness! ?

                      Viewing 10 posts - 1 through 10 (of 10 total)
                      • You must be logged in to reply to this topic.