Beotime not working

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #4030
    mdonald
    BRONZE Member
    • Topics Started 1
    • Total Posts 2

    Hi all,

    I Am Michele, a month ago I bought a BeoTime, the flute, or the Magic wand, the seller told me it did’t work, but for all this period it worked well.

    Now without a precise rule, it switches off completely, and it is enough to remove the batteries and put them back and it starts again.

    I would like to try to fix it.

    Some time ago I saw on the forum that someone had worked on it, and perhaps there was the possibility of having the service manual from the site, with a silver or gold subscription, but now I cannot find the topic, perhaps with the change of forum, I can not find it

    Thanks in advance for any help you can give me.

    M

     

    #4031
    Guy
    Moderator
    • Warwickshire, UK
    • Topics Started 3
    • Total Posts 128

    Hi and welcome to Beoworld!

    The Service Manual is indeed available on the Main Web Site ‘Products’ link (site for Gold and Silver Members) here: https://beoworld.org/manuals_view.asp?pid=1275

    The fault finding in the service manual is limited to: No display; No sound:; and no IR transmission, but it should help you dismantle (carefully!)

    I think I remember the thread that you mentioned but it is most likely on the previous forum that we can’t currently access.  It’ll be back eventually I am sure.

    I wouldn’t want to take a Beotime apart without further advice/photos!

    • This reply was modified 2 months, 3 weeks ago by Guy.
    #4184
    mdonald
    BRONZE Member
    • Topics Started 1
    • Total Posts 2

    Thank you for your replay.

    I will wait for the old forum, now the beotime seems to work, maybe the battery pack rotate in the body and loose the connection. I am trying to manage it very softly.

    thank you again.

    Michele

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.