Beomaster 8000 right channel is very hot

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #32164
    elnevo
    BRONZE Member

      Hi,

      My Beomaster 8000 is getting very hot [unable to touch] in less than a minute from turning it ON.

      First, I replaced the rear right side cooling fins assembly [with the transistors], with a good working one – didn’t help.

      Second, I replaced the amplifier board with a good working recapped one – didn’t help.

      Left channel is cool.

      Any idea what can be the problem?

      Thanks

       

      #32165
      elnevo
      BRONZE Member

        This is the unit with the heat problem I’m working on right now.

        IMG_0372

        #32167
        Ninni
        BRONZE Member

          Does it play, sounding normally, when you switch it on?

          Is there a trimmer for idle current?

          #32185
          elnevo
          BRONZE Member

            The sound is good from all speakers outputs.

            Don’t know where is the trimmer for idle current.

            #32200
            chartz
            BRONZE Member
              • Burgundy

              Good thing, the trimmers were already replaced. Follow the service manual to set bias.

              #32479
              elnevo
              BRONZE Member

                Tanks,

                I have set the trimmers using the service manual- problem solved.

              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.