Wireless PL with Beolab 8

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoLab Wireless PL with Beolab 8

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #52062
    beotex
    BRONZE Member
      • Topics Started 1
      • Total Posts 3

      I bought a BL8 (single) and very impressed with it so far. I’m considering buying a second to use with my TV setup, but having trouble testing it as a wireless PL speaker.

      Current setup is Avant NG, BL18’s in front (WISA), BL19 (WISA), and two speakers in the ceiling for surround (PL connected via Passive amps).

      The TV discovered the BL8, and I added to a speaker group. But, no matter what speaker role I assign, no sound is coming through it. I only hear sound in the setup “noise” to identify the speaker for assigning the role.

      Do I have to use a pair to be able to use them in a WISA / Wireless PL mode?  Is there some setting I need to check to enable? I have “Wireless Power Link” selected in the “Speaker Connection” setting in the app – anything else?

      Thanks!

      #52063
      beotex
      BRONZE Member
        • Topics Started 1
        • Total Posts 3

        As a follow up, I haven’t figured out the connection of the BL8, but… I did do a lot of experimenting with the different settings / speaker groups / etc. All this left me even more perplexed.

        I also grabbed my Beolab 2 from the other room to see what it would be like to have two subwoofers. I wired it through a physical powerlink cable. The TV recognizes it and works, but the BL19 shuts off. I tried assigning both to Subwoofer, then one to Sub Front and one to Sub Rear, and all combos of Sub combinations, and only one subwoofer would play. Some groups it would be the BL2, others it would be the BL19.

        Any ideas on how to use both a BL2 and BL19 with the Avant NG? Does it make any difference that the BL19 is WISA and the BL2 is wired?

        All my test setups have been in “TrueImage” and not “1:1”. I also tried 1:1 in a couple of tests without any luck.

      Viewing 2 posts - 1 through 2 (of 2 total)
      • You must be logged in to reply to this topic.

      Home Forums Product Discussion & Questions BeoLab Wireless PL with Beolab 8

      • You must be logged in to create new topics.