Troubleshooting: MX4200 switching to standby

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoVision Troubleshooting: MX4200 switching to standby

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #53320
    mr_han_man
    BRONZE Member
      • Topics Started 1
      • Total Posts 1

      Hi, apologies if this is posted in the wrong section, or if asked previously (I couldn’t find anything via search).

      I have a B&O MX4200 that has an intermittent fault, switching itself to standby (green to red LED illuminated) after differing lengths of time (e.g. over an hour or within 5 minutes of switching on).  Seems worse if the TV hasn’t been used for a while, so thought it was likely a cold solder joint issue.

      I had a look inside but could not see any obviously bad capacitors/leaks/scorching etc, just a load of dust that I carefully brushed out.  TV seemed fine for a few uses but then started switching to standby again.

      The TV is with a B&O recommended repair service, but after two months they haven’t managed to resolve the issue.  They initially re-soldered the PSU board, but the fault occurred again.  They have not confirmed if any components (e.g. capacitors) have been replaced, although I had asked for this to be done.

      Has anyone experienced this issue before who could give me some advice?  It seems quite common with the MX4000/4002, but the boards inside appear completely different to the MX4200.

      I’m sure the repair service know what they are doing, but I am inclined to collect the TV and either (a) try an alternative repair service, (b) cut my losses and look for another TV or (c) try and live with it(!).

      I have read on other forums that B&O engineers historically found these sets difficult to service, so I would be grateful for advice about cutting my losses.

      Thank you in advance for any help you can give.

    Viewing 1 post (of 1 total)
    • You must be logged in to reply to this topic.

    Home Forums Product Discussion & Questions BeoVision Troubleshooting: MX4200 switching to standby

    • You must be logged in to create new topics.