Touch screen area dead on beo6

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #11008
    ebnrob
    BRONZE Member
      • UK

      Hi all, I have a beo6 where the 4th row of buttons on the touch screen don’t work. It’s a horizontal band going the way along just above the onscreen navigation buttons. Ive done the touch screen test and the issue exists there too. Does anyone know what the issue could be? I read on the old forum it could be an issue with the ribbon cable in the screen part or the digitiser is just faulty? I’ve not taken the screen to pieces yet to check the cable, I couldn’t quite see how that came apart. Many thanks! Rob.

      #19564
      matador
      Moderator
        • Paris France

        Hi enrob,

        It was there a spamGPT answer that point to a faulty ribbon cable and warning you to be careful when opening the device to check this part.

        I mention this because this is not totally dumb. Nevertheless I believe those answer are as useful as a picture of the Pope in white puffy jacket running away from the police.

        You’ve already explore the old forums so you may already know most of what wiz know on this common issue, most digitizers ends up developing a touch fault. Sometimes its the ribbon cable but sometimes it’s not. Think someone explored another track on this but I dont remember he found a solution.

        Good luck.

        #19583
        ebnrob
        BRONZE Member
          • UK

          Hi enrob, It was there a spamGPT answer that point to a faulty ribbon cable and warning you to be careful when opening the device to check this part. I mention this because this is not totally dumb. Nevertheless I believe those answer are as useful as a picture of the Pope in white puffy jacket running away from the police. You’ve already explore the old forums so you may already know most of what wiz know on this common issue, most digitizers ends up developing a touch fault. Sometimes its the ribbon cable but sometimes it’s not. Think someone explored another track on this but I dont remember he found a solution. Good luck.

          Thanks Matador.

          Mr ChatGPT makes a good point. Since posting this though I bought a “New, old stock” replacement beo6 screen that came with a new ribbon cable attached to the screen, only to find after fitting it that this one also had a fault where the very top right didn’t register touches meaning the top page right arrow couldn’t be pressed! Such a shame as it made the beo6 look new again. The seller kindly gave me a full refund for the inconvenience. In both cases I believe it to be the digitizer at fault. So I am on the lookout for a low cost donor beo6 on ebay…

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.