no s/n in firmware, devices invisible to NL-Hardware

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #4576
    Nihil
    BRONZE Member
    • Topics Started 1
    • Total Posts 4

    Hi,

    i‘m having some trouble with 2 devices, having the same problem, a Masterlink-Gateway and a Beosound Essence MK2.

    Both devices show the s/n 00000000 in its firmware.

    They are not found by the B&O-App for setup.
    Does anybody know if there are batteries inside (like cmos-batteries in pcs) that could be the cause?

    In general both devices seem to work correctly, the essence can be used with bluetooth, dlna or airplay without problems.
    MLGW can be configured completely and is found by the Beolink2-App on ios.

    The web interface of both devices can be accessed and used completely.

    The essence does not upgrade the firmware to the latest, i think because of the missing s/n causing problems in identifying the hardware online.

    Manual software update is not possible as B&O does not give acces to the firmware-file.

    Has anybody had the same or similar problems with these or different devices or knows where to get the firmware files?

    Hope for some useful hints, thanks in advance

     

    #5556
    LabFiftyFan
    BRONZE Member
    • Topics Started 0
    • Total Posts 3

    I am having exactly the same issue with my recebtly acquired s/h Essence MK2. Can set it up as an AirPlay 2 speaker, can connect via bluetooth, can view the web interface for it but it refuses to be deteced by the B&O app.

    Serial number also shows as 00000000

    If anyone has any ideas or suggestions then I’d love to hear them.

     

     

     

    #5557
    Nihil
    BRONZE Member
    • Topics Started 1
    • Total Posts 4

    Hi, meanwhile I figured out (info from local b&o-dealer) that new mainboards/devices come with serial 00000000, the correct  serial has to be set with a configuration tool by the dealer/technican who changed the board.

    He said that this can only be done once. So there are 3 options now:

    – our devices got a new board and are not yet configured

    – our devices got a new board and the person who changed it made an error  in configuring, so it it not possible to enter the correct serial from now on

    – our devices have a defective chip where the serial is stored (as all other settings are kept in memory after losing power maybe there is a special chip for the s/n)

    I will go the dealer in the next 3 weeks and give it a try to enter the correct serial.

    #5558
    LabFiftyFan
    BRONZE Member
    • Topics Started 0
    • Total Posts 3

    @Nihil Thanks for the follow up; This is very interesting. I am hoping to get to a dealer this weekend so will take this knowelge with me; I really hope it wil be possible for us to fix our devices.

    #5559
    Nihil
    BRONZE Member
    • Topics Started 1
    • Total Posts 4

    @LabFiftyFan

    I hope to hear good news next week 🙂

     

    #5690
    LabFiftyFan
    BRONZE Member
    • Topics Started 0
    • Total Posts 3

    I took my Essence MK2 to a dealer on Saturday, they tested the unit and confirmed that it could be streamed to. They said that they had seen the missing serial number issue before and that there was indeed a fix.

    I was provided with a PDF which contained a link to a new firmware that would enable the serial number to be recovered along with instructions as to how to install this; essentially this involves connecting to the units built in wireless access point and uploading the new firmware.

    Sadly  this is hasn’t worked for me and the update process fails. I have tried doing this whilst connected to the unit via wifi where the update fails at 99% and via ethernet where the update fails at anywhere between 40-60%.

    I spoke with B&O support via phone and they have followed up this morning suggesting that unit needs to go back to a B&O technician for further diagnosis.

    The adventure continues…

    #5700
    Nihil
    BRONZE Member
    • Topics Started 1
    • Total Posts 4

    Hi again, sounds not very good but maybe it is a good step forwards.

    I contacted you via p/m

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.