Mr Roasts BG4000

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoGram Mr Roasts BG4000

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #41880
    hcraig244
    SILVER Member
      • Topics Started 7
      • Total Posts 197

      Found its way back a couple of days ago….comes with a description of the fault that reads

      “first time a record goes onto the plater after a lay off it works fine,  however if ^ is pressed followed by < then down the tone arm lifts, goes left fine but wont drop….any subsequent attempts to see a record on the plater thereafter fails……I suspect the control panel leaf spring switches (dont I always)……will take a look after the holidays when I’m sober.

      P1016855

      #41881
      chartz
      GOLD Member
        • Burgundy
        • Topics Started 3
        • Total Posts 220

        Enjoy that one Craig, I know you will!

        #41884
        hcraig244
        SILVER Member
          • Topics Started 7
          • Total Posts 197

          All reassembled and functioning flawlessly………very odd. However I will fire her up again from time to time and see if the issue returns…..I still suspect a sticking switch or switch nipple on the control panel.

          Craig

          P1016862

          #41882
          hcraig244
          SILVER Member
            • Topics Started 7
            • Total Posts 197

            Well……..got to this today, removed the control panel for a visual inspection and all looked fine, ran her up and she works perfectly?…….

            P1016856

            #41883
            hcraig244
            SILVER Member
              • Topics Started 7
              • Total Posts 197

              Had a look at the leaf spring contacts and they look clean, gave them a squirt of Deoxit non the less…..once dry I will re install the control panel and try it again….I do recall having issues in the past once the panel screws are tightened down, i think if they are not evenly tightened they flex the PCB causing erroneous signals…….P1016859

              #41885
              MrRoast
              BRONZE Member
                • Nottingham, UK
                • Topics Started 6
                • Total Posts 30

                Thanks Craig – seems very odd that it’s now behaving! Maybe it’s just me and my switch nipples ?. Will be interesting to see if it happens again.

                #41886
                hcraig244
                SILVER Member
                  • Topics Started 7
                  • Total Posts 197

                  Dave

                  I will run it periodically before you come and collect….if it happens during those tests I will document it here ;¬)

                  Craig

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.

                Home Forums Product Discussion & Questions BeoGram Mr Roasts BG4000

                • You must be logged in to create new topics.