Beosound Century – Radio issue

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #5939
    Svet
    BRONZE Member
    • Topics Started 3
    • Total Posts 10

    Hi All. I would be grateful to receive advise on how to fix a radio issue I am having on a new to me Century 1997. While memorising some FM stations the radio seems to have switched to MW Band (522 – 1610 kHz) and I am unable to switch it back to FM. The Owners Manual says to press Tune button followed by Mode to switch between FM and AM, which I have tried without luck. The Mode button does not light up and therefore does not work. Also the Century only has an FM socket for aerial, which leads me to believe that it only has FM capabilities.

    #5940
    Keith Saunders
    Administrator
    • Hampshire, England
    • Topics Started 13
    • Total Posts 89

    The Beosound Century was configured depending on market area and can be checked by the four digit type number:-

    • Type number 2651 is EU countries excluding UK and had FM Only
    • Type number 2652 is UK and had FM, LW, MW
    • Type number 2653 is US & Canada and had FM, LW, MW
    • Type number 2654 is Japan and had FM, LW, MW

    If you have a type number 2651 then MODE change will not work. Please check type numbers. If it is one of the other type numbers then the instructions you were using are correct. See below for confirmation.

    Century

    #5941
    Svet
    BRONZE Member
    • Topics Started 3
    • Total Posts 10

    Thank you very much for the prompt reply. I could not find the 3 digit number but the serial number is 2457516 and I am pretty sure the system is imported from Danmark. Any suggestions?

     

    #5948
    Keith Saunders
    Administrator
    • Hampshire, England
    • Topics Started 13
    • Total Posts 89

    I could not find the 3 digit number but the serial number is 2457516 and I am pretty sure the system is imported from Danmark. Any suggestions?

    There is always a FOUR (4) digit type number on every B&O product unless the label has been removed. If it was purchased second hand from someone in Denmark other than B&O then it will be FM only.

    #5954
    Svet
    BRONZE Member
    • Topics Started 3
    • Total Posts 10

    The label is partially damaged bit i agree it is a European model hence only theFM socket and the Mode button does not livht up. However the problem still remains that I can’t switch it back to FM. It goes 522-1611 (MW) and then after pressing Tune + StepĂ— 279-150 (AM) After pressing the same buttons goes back to MW.

    #5955
    Keith Saunders
    Administrator
    • Hampshire, England
    • Topics Started 13
    • Total Posts 89

    Well, the tuner has preset adjustments which may have been changed causing the problem.

    Also we are not 100% sure of the model type because of the damaged label, but we could find out for certain by putting the unit into test mode.

    To put the unit into “Test Mode” do the following:-

    • Unplug the unit form the mains outlet wait 2 minutes
    • Plug unit into mains outlet and within 30 seconds press DOT 2650
    • The display will show 8888 when unit is in Test Mode

    NOTE: DOT above means standby button

    When in Test Mode press 08 to display tuner variant

    • 0 in display means tuner error
    • 1 in display means EU but not UK
    • 2 in display means UK
    • 3 in display means USA
    • 4 in display means Japan

    You will need to get a copy of the service manual if you want to check the tuner adjustments as its not that simple.

    Tuner

    #5956
    Svet
    BRONZE Member
    • Topics Started 3
    • Total Posts 10

    Thank you Keith! Have entered into test mode and got a “1”. Have also downloaded the service manual but not sure what to do next. Is it a question of testing the different elements with a voltmeter? Is there a way of resetting the radio so that it goes back to FM mode? Thank you again.

    #6040
    Svet
    BRONZE Member
    • Topics Started 3
    • Total Posts 10

    Hi Keith. Are you able to give any further advice on the next step. I am not sure on how to use the table and on the next steps. Thank you!

     

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.