Beoplay V1 screen error

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoPlay Beoplay V1 screen error

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #55781
    Alexander Steen
    SILVER Member
      • Topics Started 2
      • Total Posts 4

      Hello,
      I am in a situation where my BeoPlay V1 has suddenly started showing white vertical lines.
      This occurs when white text appears on the screen (please see the attached picture). I am unsure what could be causing this problem.
      Could it be an issue with the LCD display itself or possibly another component in the TV?
      and could one imagine that this could be fixed at a reasonable price?

      I look forward to hearing if anyone might have a good suggestion πŸ™‚

      Attachments:
      You must be logged in to view attached files.
      #55802
      jacek1313
      BRONZE Member
        • Topics Started 0
        • Total Posts 7

        In the BV10-32 I once repaired, I had a similar defect, a damaged LCD screen. You can disassemble the screen and check the ribbons connecting the T-Con – LCD screen.

        BV10-32 LCD LTA320HJ05 Org 92 pins

        #55804
        Alexander Steen
        SILVER Member
          • Topics Started 2
          • Total Posts 4

          Hello Jacek1313.
          Thank you for your response.
          It looks quite similar to my picture.
          In your case, did you have to replace the screen or just the ribbon cables or the T-con module?
          I have now opened and checked the ribbon cables from the T-con to the LCD screen.
          One of them looks a bit sketchy. A couple of the contact points are not quite the same height.
          Do you know where one could buy new ribbon cables by any chance? πŸ˜€
          Thank you so much for your help and time πŸ˜€

          #55807
          jacek1313
          BRONZE Member
            • Topics Started 0
            • Total Posts 7

            I had to replace the LCD screen. It is also possible that there is damage to the driver board under the LCD housing. Large selection of cables on Ebay.

            LTA400 Drivers

            LTA320HF05_2__

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.