Beomaster 2000 Type 2911 – FM and sound Problem.

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums General Discussion & Questions Beomaster 2000 Type 2911 – FM and sound Problem.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #56052
    Thorsten Stumpf
      • Topics Started 1
      • Total Posts 1

      Hello Forum,
      Noobie here in the Beoworld πŸ™‚

      I purchased from ebay a broken Beomaster2000 Type2911 Sern. 2872003
      The unit is in really good condition, it turned on with a relay click and all the sensor buttons and lights are working.When i press the front “Programming” the lid opens automatically πŸ™‚

      Here comes the tricky part:

      I get no noise from the FM input connected with 75ohm areal antenna. All the 5 station are complete silent, when i try to tune in there is no buzzing sound or tuning light.By changing to TP or Phono i get a low ticking noise. I connected a music player over the 7 DIN TP input and can hear music, but it is low volume, distorted with the ticking noise.Volume up and down is making a small difference,muting works.Bass,balance and treble seem to work also.

      I took the unit appart and from visual inspection i can see no bulging or leaking caps.On the power input board i started to change a ROE 470mf cap, my component tester showed spot on value and low ESR on this one.

      So i’am not sure if changing all the ROE and electrolytic caps will resolve the issue, maybe i have 2 faults no FM tuner and problem in the Amp section?

      What should i do for further troubleshooting and repair?

      Thank you for your help.

    Viewing 1 post (of 1 total)
    • You must be logged in to reply to this topic.