Beolab speaker repairs

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #13022
    a2bur
    GOLD Member
    • Topics Started 2
    • Total Posts 5

    Hi all . Can anyone give me help repairing one each of three B and O speakers , beolab 4000 , 8000 and beolab 1 , all show red standby but won’t go green . Power links tested with working speakers . Had the board out on the 4000 and can’t see any burning but the sponge has turned to glue. I was and engineer for 45 years and am confident I can repair with detailed guidance , had quotes that are more than they are worth , just need instructions and where to get the components in the Uk if someone can help . Richard

    #13023
    Mr10Percent
    BRONZE Member
    • Topics Started 4
    • Total Posts 286
    #13074
    KolfMAKER
    BRONZE Member
    • The Netherlands
    • Topics Started 15
    • Total Posts 132

    Hi A2bur,

    Some checks on what mentioned:

    1. ”Powerlinks tested with working speakers” – Does that mean that when connected via Powerlink, all speakers do switch from Stand-by/Off to On?
    2. If they work with Powerlink, is your issue of not switching to On, with the RCA/Line input?

    What you mention about sponge, probably is about the foam: fallen apart and sticking to PCB’s and components. If so, this is a common problem and you will have to clean everything out.

    This foam rot can cause shorts or even eat away parts of the copper traces.

    can you share pictures of this?

    #13087
    a2bur
    GOLD Member
    • Topics Started 2
    • Total Posts 5

    Thanks MR10 for the manual link and have downloaded the 4000 one . The power link works with  a working speaker but the 4000 stays red when the p/link is returned . Not tried line input yet . I’ll open it up again and clean , do i have to discharge anything ? I’ll get some pictures when I get it open . I’ll see how I get on with this 4000 before I look at the 8000 and the beolab 1 , it’s only one of each pair the has the constant red condition .

    #13093
    a2bur
    GOLD Member
    • Topics Started 2
    • Total Posts 5

    Line in works from the headphone socket on the Beomaster 3500 ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.