Beogram 6002/8002/TX etc. platter issue

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoGram Beogram 6002/8002/TX etc. platter issue

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #42862
    PeteV
    BRONZE Member
      • Topics Started 1
      • Total Posts 4

      Hi,

      I’m currently restoring a BG TX which has some of the conductive paint coming off on the platter , as shown on the picture. Are there any suggestions about colour matched paint which I could use to repair?

      Many thanks

      #42863
      PeteV
      BRONZE Member
        • Topics Started 1
        • Total Posts 4

        Hmm, am I the only one who has this problem?

        #42864
        Mark-sf
        BRONZE Member
          • Topics Started 0
          • Total Posts 297

          That paint is not conductive as it only needs to be non-reflective. I don’t have a specific recommendation as B&O never published this to my knowledge.

          #42866
          Mark-sf
          BRONZE Member
            • Topics Started 0
            • Total Posts 297

            Its conductivity is not functional since it’s used optically to be non-reflective for record edge detection.

            #42865
            PeteV
            BRONZE Member
              • Topics Started 1
              • Total Posts 4

              As far as I can measure, the paint seems to be conductive, but to be honest this is probably not relevant to repairing/repainting small areas. The main issue would be colour match. As far as I can see, it appears to be a very dark matt grey colour.

               

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.