Beogram 6002/8002/TX etc. platter issue

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #14277
    PeteV
    BRONZE Member
    • Topics Started 1
    • Total Posts 4

    Hi,

    I’m currently restoring a BG TX which has some of the conductive paint coming off on the platter , as shown on the picture. Are there any suggestions about colour matched paint which I could use to repair?

    Many thanks

    Attachments:
    You must be logged in to view attached files.
    #15092
    PeteV
    BRONZE Member
    • Topics Started 1
    • Total Posts 4

    Hmm, am I the only one who has this problem?

    #15102
    Mark-sf
    BRONZE Member
    • Topics Started 0
    • Total Posts 157

    That paint is not conductive as it only needs to be non-reflective. I don’t have a specific recommendation as B&O never published this to my knowledge.

    #15258
    PeteV
    BRONZE Member
    • Topics Started 1
    • Total Posts 4

    As far as I can measure, the paint seems to be conductive, but to be honest this is probably not relevant to repairing/repainting small areas. The main issue would be colour match. As far as I can see, it appears to be a very dark matt grey colour.

     

    #15296
    Mark-sf
    BRONZE Member
    • Topics Started 0
    • Total Posts 157

    Its conductivity is not functional since it’s used optically to be non-reflective for record edge detection.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.