Beogram 5500: Arm “sliding” across record

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7051
    TimeBandit
    BRONZE Member
    • Topics Started 3
    • Total Posts 7

    I seem to recall others experiencing what I’m about to describe, but I can’t find the threads. . . .

    When I press Play, the arm sets down correctly, but then begins sliding across the record toward the center spindle. It’s as if it doesn’t have the correct tracking force, even though it does. Thoughts?

     

     

    #7052
    Isthatthebeotime
    BRONZE Member
    • Topics Started 6
    • Total Posts 43

    Just a quick question is the plastic guard cap down on the cartridge? If not flicked up fully this can cause it to just skip across a record!

    #7057
    TimeBandit
    BRONZE Member
    • Topics Started 3
    • Total Posts 7

    Worth asking, because stupid stuff happens, but yes, the stylus guard is up.

    #7063
    TimeBandit
    BRONZE Member
    • Topics Started 3
    • Total Posts 7

    So I did find one other instance of the same issue. Unfortunately, no resolution was ever reached.

    https://archivedforum.beoworld.org/forums/t/31724.aspx

     

    #7064
    Die_Bogener
    BRONZE Member
    • Topics Started 1
    • Total Posts 35

    Is the MMC ok?

    Sometimes the stylus is broken and the needle is bent upwards or even complete missing… then the MMC case slides over the record…

    #7066
    TimeBandit
    BRONZE Member
    • Topics Started 3
    • Total Posts 7

    Yep, I just about to post that I looked more closely at my cartridge, and sure enough the stylus has broken off. Oh well.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.