Beogram 4004 solenoid problem?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #8781
    Hsmyth
    BRONZE Member
    • Topics Started 1
    • Total Posts 1

    Hello! Long time reader and occasional poster of the old forums here. (I was unable to restore my account and have created a new one.)

    I’m seeking advice on repairing a Beogram 4004 that a I recently purchased. The unit appears to be in vey good condition, and as far as I can tell is functioning well, except for the problem listed below.

    I have owned a 4002 for over 10 years, which to my knowledge is identical in most way to the 4004, and have completed small repairs. In particular I’ve worked on the tonearm mechanism, which seems to be the problem area on the 4004.

    The Problem:

    At a high level, the tonearm is not dropping.

    After pressing START, everything fires up and the tonearm moves as expected, but the solenoid doesn’t engage with enough force to move the tone arm mechanism and drop the arm.

    It appear that the solenoid engages, but doesn’t have enough force to move Arm A (service manual image attached). The solenoid piston and arm actuator move a small amount, sort of popping out then right back in. I have a video of this here:

    https://youtube.com/shorts/dkAxuUtzHdA?feature=share

    If I remove Spring E, which puts tension on Arm A, the actuator fully extends, and the tonearm drops as expected. Of course this leaves the tonearm down, so was just a troubleshooting idea I tried. Video here without the spring:

    https://youtube.com/shorts/06xM82yWxss?feature=share

    Work done so far:

    I have dismantled, cleaned, and lubricated the tonearm mechanism following instructions form beolover here: https://youtu.be/IxIxHb8sZdg

    Any clues on what I should try next?

    Could the solenoid not be receiving enough power?

    I have the solenoid from my 4002 (which is now for parts) which I could try to swap in, but I wanted to see if the greater minds here had any other ideas before I try swapping in the spare solenoid.

    Should I test the solenoid with a multimeter, and if so what’s procedure to do that?

    Many thanks if you can help. H

     

     

     

    Attachments:
    You must be logged in to view attached files.
    #8846
    spassmaker
    BRONZE Member
    • Topics Started 3
    • Total Posts 49

    Hi

    For me it seems that the current limmiting circurit 1TR9 and 1TR10  is always on, or the Darlington Transistor 1IC4 is not working proper.

    I would look for all 3 transistors maybe just put some new ones in, sometimes they mesured as good with a DMM but don’t work because of lack in HFE.

    Important to control or renew is 1C23 (100uF). If this cap has not enough capacity it will put the curent limiting circurit on too fast so that the solenoid can’t engage.

    Regular transistors will work e.g. BC 547 cost only a few cents.

    Darlington should be at least a TIP125.

    Let us know if you got any progress.

    Kind regards

    Christian

    #8851
    sonavor
    BRONZE Member
    • Topics Started 0
    • Total Posts 25

    I have fixed the BG400x sticking solenoid problem like this.  The information on the solenoid is towards the end of the post.

    -sonavor

    #8901
    efjay777
    BRONZE Member
    • Topics Started 0
    • Total Posts 2

    I’m having the same issue with my 4004 before and after cleaning and regreasing, though it’s sporadic. Given the electrical profile (should be 30v jolt then immediately diminished), I’d suspect a capacitor issue. Next time it does it I’ll try to scope it. And I’ll need to consider the schematic.

    #8962
    efjay777
    BRONZE Member
    • Topics Started 0
    • Total Posts 2

    I was having the same issue but haven’t been able to replicate it, but for what it’s worth here’s the measurements I’m getting in a operational state.

    Beo4004solenoid

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.