Beocenter 8500 – tape recording on left channel only

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoCenter Beocenter 8500 – tape recording on left channel only

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #55952
    CharlieWednesday
    GOLD Member
      • Liverpool
      • Topics Started 22
      • Total Posts 100

      A bit of background first – I have a working Beocenter 8000 which I restored myself, but I decided I wanted to upgrade to the Beocenter 8500, for several reasons – I wanted some active speakers and MCL link room (the BC8000 does not allow either), and I wanted the grey panels of the BC8500 to match my Beogram 8500 turntable

      I bought one really cheap on eBay but it was a write off – cassette deck beyond repair and the CD player was temperamental too – I decided to keep it for parts and get another BC8500 for a bit more money, also from eBay.

      This one was sold as working but I have had an issue with the tape deck – it plays cassettes fine, but if recording, it only appears to record on the left channel.  When I play back anything I have previously recorded on my BC8000 it plays fine both channels, but if I record on the BC8500 only the left channel can be heard on playback.  Trial and error therefore; it’s a recording issue, not a playback issue.

      I’ve got the service manual but I can’t make any sense of that specific problem – any ideas?

      Incidentally, it’s the ‘Type 2’ tape deck mechanism.

      #55954
      CharlieWednesday
      GOLD Member
        • Liverpool
        • Topics Started 22
        • Total Posts 100

        Problem solved – I had opened it up to see if anything was loose. I couldn’t find anything wrong but when I put it back together, it worked!  I’ll assume something was a bit loose and the process of opening up, fidgeting around and then closing it back up has fixed it, somehow!

      Viewing 2 posts - 1 through 2 (of 2 total)
      • You must be logged in to reply to this topic.