Beocenter 2

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #7607
    Beogogo
    GOLD Member
    • Topics Started 3
    • Total Posts 16

    I purchased a cherry Beocenter 2, had it serviced and am ready to set it up. Right now, I just want to use it for listening to CD’s. I can connect the RCA audio out jacks to the aux input of my Beosound Edge and it works great, but no remote works. 2 Beo4’s and a Beo One. I know they work, so it’s not them. I suspect it was used in a system with a TV, as I have seen the message about adjusting sound via the TV. I’ve tried the PL jack, but again no remote works. I do get sound, but reduced compared to the aux. I have tried to find anything in the old forums, and did see a mention of using a special PL cable, is this what my problem is? Thanks!

    #7608
    trackbeo
    BRONZE Member
    • Topics Started 4
    • Total Posts 96

    Talking through my hat because I don’t own one myself, but this sounds like the classic “Option 0” setting where the attached TV is supposed to process the IR remote.  Everybody says “just do Sound / 1 / Store on your Beolink 1000 remote, while the power is off.”    The manual fragment below confirms & tells how to do it with a Beo4:

    Beocenter 2 A.OPT settings

    I believe it’s perfectly normal for Aux output to be louder than PowerLink because PowerLink level is controlled by the volume control.  I was recently reminded of that the hard way, accidentally plugging my Beocenter 9500 Aux out straight into a power amp: Yikes that was loud.

    #7620
    Beogogo
    GOLD Member
    • Topics Started 3
    • Total Posts 16

    No luck. I even reset it to defaults. It still says go to the TV to adjust sound. Maybe is is the power link cable. Thanks for the suggestions anyway.

    #10730
    Beogogo
    GOLD Member
    • Topics Started 3
    • Total Posts 16

    As an owner of a cherry Beocenter 2, I was in the same situation. No matter what I tried, I couldn’t get it to work. Until I powered the Beocenter 2 down and tried it and worked the first time! And it works for the two Beo4 and Beo One remotes. I hav noticed that if you unplug the unit, you might have to go through the same process after plugging it in again

    #10750
    Tignum
    GOLD Member
    • Netherlands
    • Topics Started 1
    • Total Posts 95

    Beogogo, thanks for solving the mystery so other readers can benefit! But… you are the OP right? 🙂

    #10764
    Beogogo
    GOLD Member
    • Topics Started 3
    • Total Posts 16

    OP?

    #10769
    Tignum
    GOLD Member
    • Netherlands
    • Topics Started 1
    • Total Posts 95

    The Original Poster of the thread.

    #10787
    Beogogo
    GOLD Member
    • Topics Started 3
    • Total Posts 16

    lol, I was. I didn’t even notice. Well I fixed it myself. Sorry for the confusion.

    #10792
    Tignum
    GOLD Member
    • Netherlands
    • Topics Started 1
    • Total Posts 95

    😆 Great that you got it working! And thanks again for posting how. Cheers, Johan

    #10859
    BeoTool
    BRONZE Member
    • Topics Started 2
    • Total Posts 27

    I purchased a cherry Beocenter 2, had it serviced and am ready to set it up.!

    May I ask where you had it serviced? Would love to acquire a BC 2 someday.

    #11200
    Beogogo
    GOLD Member
    • Topics Started 3
    • Total Posts 16

    Modular Electronics
    https://aminaaudio.com

    They repaired a Beosound 4000 for me in addition to the Beocenter 2. Very knowledgeable and quick turnaround.

    #11201
    BeoTool
    BRONZE Member
    • Topics Started 2
    • Total Posts 27

    TY! 🙏🏼

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.