Sign in   |  Join   |  Help

Search

  • Re: Introduction BeoVision Harmony

    So, the big question is will you in the future when 8K and eventually 16K screens are more available (and affordable) be possible to upgrade the current LG 4K screen with an 8k or 16k screen only, i.e. retain the B&O speakers/stand/controller but replace the screen? Is the 4k driver components in the B&O part of the unit, or in the LG screen? I would assume in the screen, but with B&O you never know, they prefer to sell you a complete new unit rather than upgrade.
    Posted to General Discussion & Questions (Forum) by Lareny on Thu, Oct 31 2019
  • Re: BeoSystem 5

    It would be nice to think they would consider a Beosystem 5, but it seems their new Italian CEO is focused on play and a younger less discerning audience than on high end quality and their "old" loyal customer base. Given that the TV's (and the new Harmony is no exception) are based around LG displays, maybe B&O should abandon TV's (rumours are they may) and develop a stylish AV processor around the Beosound5/Beomaster5, call it Beosystem 5, and give it all the features we want
    Posted to General Discussion & Questions (Forum) by Lareny on Mon, Oct 28 2019
  • Re: Beolab 8000 no sound

    I would love to, but unfortunately I am currently working in Abu Dhabi in the United Arab Emirates so that would be cost prohibitive to send them. The local Dubai B&O guys just ran away scared, but one of them suggested it was not the amps, it is either something simple as a fuse or the relay.
    Posted to The Workbench (Forum) by Lareny on Mon, Jul 3 2017
  • Re: Beolab 8000 no sound

    I guess if there is foam rot short circuiting the IC board and solder post deterioration, it is a matter of whether you want to drag one speaker at a time for repair, or get them both done and over with. I chose the latter, better to be safe than sorry and sitting and listening to your just fixed speaker and then have the other go out. I have an even bigger problem which is maybe why do it now is better than later. I have two pairs of Beolab 5000 active flat panel speakers (the oldie but goodies
    Posted to The Workbench (Forum) by Lareny on Mon, Jul 3 2017
    Filed under: internal fuse, Beolab 8000, Repair, fuses, capacitors, Circuit boards, Beolab 5000
  • Re: Beolab 8000 no sound

    OK, speaker fixed by local tech, solder points corroded and IC board shorted out (obviously due to age and possible foam rot deposited on board). Not cheap, but not too bad. About $150 and it is back in business.
    Posted to The Workbench (Forum) by Lareny on Mon, Jul 27 2015
  • Re: Beolab 8000 no sound

    Sounds like a good old "oops" from B&O's design department............would have thought they had fixed it by now, but mine are older speakers so I am expecting the worst (but hoping the best) and as I said earlier, assume once one is fixed the second will go shortly thereafter.
    Posted to The Workbench (Forum) by Lareny on Mon, Jul 13 2015
  • Re: Beolab 8000 no sound

    Will do, let's see if he is any good. In this part of the world I don't have the highest expectations as the quality of tech's in general is somewhat dubious, and then again sometimes surprisingly good, it's a toss of the coin. I'll hopefully get a call in the next few days with the diagnose, and will post the diagnostics.
    Posted to The Workbench (Forum) by Lareny on Sun, Jul 12 2015
  • Re: Beolab 8000 no sound

    Thanks all. I ended up getting hold of a B&O service tech, so took it to him last evening and will see what he can do. I thought however when circuits, transformer or power supply goes, the status light would not go from Red to Green. When however it does this, I cannot actually hear the relay turning the speaker on. Guess I'll get one fixed and the other will go shortly thereafter. Let's see.
    Posted to The Workbench (Forum) by Lareny on Sun, Jul 12 2015
  • Re: Beolab 8000 no sound

    Agreed, foamrot doesn't behave as this does. Guess it is a trip to the B&O service center....... Thanks.
    Posted to The Workbench (Forum) by Lareny on Sat, Jul 11 2015
  • Beolab 8000 no sound

    Hi. I have a pair of Beolab 8000 speakers connected through a Beolab 2 to my Beosound 5 Encore. One of the speakers suddenly started dropping out, and when doing so the LEd light turned orange. After a few power off and on and disconnecting power, it went back to working, only to next time do the same. Now however, it only displays red light in standby and green light when turned on, however NO SOUND! I thought when green light is on, all is OK, but obviously green light can be on and no sound comes
    Posted to The Workbench (Forum) by Lareny on Fri, Jul 10 2015
    Filed under: Beolab 8000
Page 1 of 1 (10 items) | More Search Options
Beoworld Security Certificate

SSL