Reply To: Beocenter 8000 tape deck clicking issue

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoCenter Beocenter 8000 tape deck clicking issue Reply To: Beocenter 8000 tape deck clicking issue

#55380
anthony elliot
BRONZE Member
    • Topics Started 0
    • Total Posts 8

    Hi Guys, My apologies for using this thread, but don’t know where to turn (could you possibly point me in the right direction?)

    I wonder if you could help. I recently bought a Beocord 7000 (plus Beomaster, Beogram CD etc etc) I was over the moon getting it (auction). I took a chance at the auction (cost a wee bit), anyway when I set it up the Beogram CD didn’t play, lucky for me it was just a head clean. When I got to the Beocord 7000, the head/transport did not move (I am gutted) anyway I was able to get access to the cassette unit (I am ok to a certain level of disassembly)  and can see that the “big belt” had failed. I wonder if you could help me… I have obviously got the unit out, but unsure how to go further t0 access the belts, also I do not know where to get the right belts and of suitable quality. I think I have the Bang & Olufsen Beocord 7000 Version 2 tape head (if that makes sense). I have attached photos. Any help would be appreciated or pointing me in the right direction.

    Forgive me for using the thread, I am new to Beoworld site. I just love the look of the B&O system and really wanted them to be OK.

    Sincerely Tony

     

    Attachments:
    You must be logged in to view attached files.

    Home Forums Product Discussion & Questions BeoCenter Beocenter 8000 tape deck clicking issue Reply To: Beocenter 8000 tape deck clicking issue

    • You must be logged in to create new topics.