Reply To: Beomaster 901 stereo light not working – FIXED was weak FM aerial signal

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoMaster Beomaster 901 stereo light not working – FIXED was weak FM aerial signal Reply To: Beomaster 901 stereo light not working – FIXED was weak FM aerial signal

#53792
HatOfTheCat
BRONZE Member
    • Topics Started 3
    • Total Posts 7

    “if you have 0v at the base then the light is not turned on. have you tried to remove the transistor and measure the base voltage again (to see if the transistor is not base/emitter shorted) you can even measure 2C56 is this cap is not shorted/or has low impedance compared to the 33K resistor. Especially since it seems to be tantalum”

    Yup, pulling it was my default next step, was just trying to see if there was a common known other cause for the lamp fault before diving in.  Its the same MPSA13 type transistor that I think was root cause of failure that cascaded through the power amp stage transistors so I am suspicious of it anyway.  Have a few new ones in packet so it will get pulled and tested.  BTW the recap also included the tantalum ones including 2C56 (yellow ones in the photo of board, the blue ones are some of the many many many original orange electrolytics… they looked super cool but a couple even had visibly cracked cases).

    Home Forums Product Discussion & Questions BeoMaster Beomaster 901 stereo light not working – FIXED was weak FM aerial signal Reply To: Beomaster 901 stereo light not working – FIXED was weak FM aerial signal

    • You must be logged in to create new topics.