Sign in   |  Join   |  Help

Search

  • Re: Beomaster 8000 Restoration

    Over the last month I did figure out and fix another issue. FM Issue - some progress. I figured that there was no sound from the speakers when FM was set to Auto Tune. But when I switched to Manual Tuning, I did get audio but only on the left speaker. If I switched to Mono both the speakers worked fine. Also confirmed that PCB 2 was not the issue by swapping left and right outputs (p10). I did get output from left. Past posts indicated 3IC202 (AD 10/278) could be the culprit and sure enough replacing
    Posted to General Discussion & Questions (Forum) by dahiyas on Sun, May 9 2021
  • Re: Beomaster 8000 Restoration

    I am back on my project after a long break. So I did end up putting the jumpers. The system has been playing well for the last 2 months. I haven't put the screws as yet as there are 2 issues: 1. Even when the speaker volume is set to 0, I can hear the music from the speakers. Even though its low, its there. In fact, I continue to hear the volume for couple of seconds after the system is put in standby. Volume offset ? I did replace the trimmers on the tone control board but didn't calibrate
    Posted to General Discussion & Questions (Forum) by dahiyas on Thu, Mar 18 2021
  • Re: Beomaster 8000 Restoration

    Looks like I we may have found the culprit. I was checking on the crystal oscillator X2 (the one on the left) and trying to see how to take it out. I poked on the 3 vias right above x2 (with a plastic spudger). And decided to try one last time before removing the CPU/Display boards. The system came out of standby on the first attempt and I tried on/off combination many times - worked fine. Connected a source and let the system run for about 3-4 hrs..No issues since then. Looks like everything works
    Posted to General Discussion & Questions (Forum) by dahiyas on Sun, Jan 24 2021
  • Re: Beovox MS150

    No Sonavor. I haven't reached out to them as yet. I will try speaking to them on Monday.
    Posted to General Discussion & Questions (Forum) by dahiyas on Sun, Jan 24 2021
  • Re: Beovox MS150

    Thanks Sonavor, I did call Freeman-Tuell . They said that if the voice coils are frozen then they wont be able to do anything and they were not sure about the cone also. Maybe I will ask them to "try"..worst case I am down by shipping fees.
    Posted to General Discussion & Questions (Forum) by dahiyas on Fri, Jan 22 2021
  • Re: Beomaster 8000 Restoration

    Thanks Sonavor..Yes !! I did see the post about the new PCB. Am sure many folks will be waiting for that one. Initially, the 5v regulator/capacitor were an issue. Replaced those and 5v problem was fixed. Now it's stable at 4.9v. Other than that only other thing I checked was the voltage for display PCB, which was ok. I did try a Beomaster Terminal remote. The system only responds to the remote when not in "hang" state. Which is again pointing to the CPU board being a problem. I will
    Posted to General Discussion & Questions (Forum) by dahiyas on Fri, Jan 22 2021
  • Re: Beomaster 8000 Restoration

    Thanks Sonavor..Yes !! I did see the post about the new PCB. Am sure many folks will be waiting for that one. Initially, the 5v regulator/capacitor were an issue. Replaced those and 5v problem was fixed. Now it's stable at 4.9v. Other than that only other thing I checked was the voltage for display PCB, which was ok. I did try a Beomaster Terminal remote. The system only responds to the remote when not in "hang" state. Which is again pointing to the CPU board being a problem. I will
    Posted to General Discussion & Questions (Forum) by dahiyas on Fri, Jan 22 2021
  • Re: Beomaster 8000 Restoration

    Thanks Sonavor..Yes !! I did see the post about the new PCB. Am sure many folks will be waiting for that one. Initially, the 5v regulator/capacitor were an issue. Replaced those and 5v problem was fixed. Now it's stable at 4.9v. Other than that only other thing I checked was the voltage for display PCB, which was ok. I did try a Beomaster Terminal remote. The system only responds to the remote when not in "hang" state. Which is again pointing to the CPU board being a problem. I will
    Posted to General Discussion & Questions (Forum) by dahiyas on Fri, Jan 22 2021
  • Re: Beovox MS150

    The 6.8mH coil arrived and the size is similar to the original coil. So both the crossover boards are good now. UPS was good and approved my claim. So the MS150 speakers are "free" for me now. Need to replace the surrounds on the 10" woofers and they will be good. 8" - Both of them were frozen. I followed instructions on Sonavors post (https://forum.beoworld.org/forums/t/638.aspx?PageIndex=4) and was able free up the voice coils. John - Were you able to use the restored 8"
    Posted to General Discussion & Questions (Forum) by dahiyas on Thu, Jan 21 2021
  • Re: Beomaster 8000 Restoration

    Finally am back on the project. On the positive side I fixed the unresponsive tuner dial. Replacing the OP240A fixed the issue. (same as the volume sensor module - https://beolover.blogspot.com/2018/02/beomaster-8000-repaired-rotary-volume.html). Added Beolab 5000 speakers to my collection. So the BM8000 works well .....only when it works. Issues - 1. There are times it wont come out of standby..pulling out power and plugging it in again fixes the problem. Takes couple of retries sometimes. 2. When
    Posted to General Discussion & Questions (Forum) by dahiyas on Thu, Jan 21 2021
Page 2 of 15 (142 items) < Previous 1 2 3 4 5 Next > ... Last ยป | More Search Options
Beoworld Security Certificate

SSL