WallyGator

Forum Replies Created

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • in reply to: Beogram 8002 cleanup #8472
    WallyGator
    BRONZE Member

      Update!!

      Cap kit installed and the turntable operates like new again!  Had to disassemble it twice because of a loose connector but all in all, not as difficult as I thought it would be.

      Thanks for your help!

      in reply to: Beogram 8002 cleanup #6794
      WallyGator
      BRONZE Member

        OK.  Cap kit has been ordered.

        in reply to: Beogram 8002 cleanup #6779
        WallyGator
        BRONZE Member

          Got an Amazon link?  I’m not finding anything that would be worth buying.  There are many assortments that contain a whole range of capacitors (most of which wouldn’t get used).  Is that what you mean when you say ‘kit’?

          in reply to: Beogram 8002 cleanup #6771
          WallyGator
          BRONZE Member

            Well…sadly…replacing the servo belt and cleaning the spindle didn’t fix the issue.  I guess replacing the caps is next.  Seems odd that after operating the << & >> keys and watching the tomearm travel back and forth accross the platter for a few minutes would get the unit to perform normally.  If the caps were bad, they’d always be bad, no matter how long you moved the tonearm back and forth.  That’s what made me think is was a mechanical issue.

            Anyways…anyone know where to get a replacement set of capacitors in the US?

            in reply to: Beogram 8002 cleanup #6715
            WallyGator
            BRONZE Member

              The belt on the TT is original so I bought a new belt.  Should get here next week.

              When pressing play on the TT, the tonearm moves out slightly but doesn’t reach the edge of the record.  It then returns home and shuts off.  If I use the < & > keys to move the tomearm back and forth across its entire range a few times, the play button begins working correctly.  It’s almost as if it neeeds to stretch & warm up before exercising.  Seems to work OK after a “warm up”.
              I’ll be carefull with any cleaner I use.

              in reply to: Beogram 8002 cleanup #6613
              WallyGator
              BRONZE Member

                Thanks, Sonavor.

                I’ll try to clean as best I can without removing the tonearm assemply.  That last link had the best photos for this part of the job.  If that doesn’t fix the reluctant tonearm assembly, I’ll have to dig a little deeper.  Thanks for the info!

              Viewing 6 posts - 1 through 6 (of 6 total)