Sign in   |  Join   |  Help

Search

  • Re: Beomaster 5000

    Thanks Dave, Oddly enough, your quick fix worked. Now the spare is working great, a little rough looking and the drop down door is temperamental, but sounds right. Why? Even oddlier enough, the original one is working as well. I turned the power strip it was plugged into off so it wouldn't turn on with the remote when I tested the spare. I needed to turn the strip back on, and on a whim tested the original. It fired right up and was its old sweet sounding self. More good news is that while I
    Posted to General Discussion & Questions (Forum) by georganic on Sat, Sep 26 2015
  • Re: Beomaster 5000

    [quote user="hemenex"] Had exactly the same problem on a BM5000 that had not been used for 5 years this friday. Playing for 2 minutes then no sound on whatever input selected. Replaced C1 on board 3 - was a "golden" ROE 100µ/25V (and replaced the other 4 found on all the boards as well). C1 had a shortcut, the other ones at most 40% of the original value. So it's not always the famous red ROE's that fail. Long shot but probably helpful. Best, hx [/quote]Thanks hx
    Posted to General Discussion & Questions (Forum) by georganic on Thu, Sep 24 2015
  • Re: Beomaster 5000

    Does sound tempting...but scary. Maybe I'll try replacing the board with the spare. That will let me practice disassembling.
    Posted to General Discussion & Questions (Forum) by georganic on Sun, Sep 20 2015
  • Beomaster 5000

    I have a BeoSystem 5000 that has operated flawlessly for 4 years of ownership. Until yesterday. I fired it up and waited for the record to start paying and...nothing. Tried the tape deck, radio couldn't here a sound. Turned the volume up (default is 3:2) and around 5:0 I started to hear faint sounds. At 6:0 I could hear the music, but it sounded like it was playing at approximately 2:0. This was across the board, Beogram, Beocord and radio. I searched the forums. First I tried the headphones
    Posted to General Discussion & Questions (Forum) by georganic on Sun, Sep 20 2015
  • Re: BeoCenter 7000

    Thanks, I hadn't noticed that. Mine has 2 X 5 pin dins, 1 is mic and one is tape in. Can I still press P1?
    Posted to General Discussion & Questions (Forum) by georganic on Sat, Dec 13 2014
  • BeoCenter 7000

    Just picked up the above unit. Question: Is there a way to hook up a CD player and/or MP3 player?
    Posted to General Discussion & Questions (Forum) by georganic on Sat, Dec 13 2014
  • Re: Beoxox RL 35

    Thank you. Is that repairable?
    Posted to General Discussion & Questions (Forum) by georganic on Wed, Oct 1 2014
  • Re: Beoxox RL 35

    Beovox, not Beoxox
    Posted to General Discussion & Questions (Forum) by georganic on Wed, Oct 1 2014
  • Beoxox RL 35

    Just purchased a pair of these on eBay. One of the speakers has something rattling around inside. Can't figure out how to get them apart. Only screws are the 2 plastic ones that hold the straps and the t small screws that hold the speaker wire spring clip block. Anybody?
    Posted to General Discussion & Questions (Forum) by georganic on Wed, Oct 1 2014
  • Re: Thanks to Dillen

    Thanks for that, Beobuddy, now I just need a schematic to tell which wires are what color...
    Posted to General Discussion & Questions (Forum) by georganic on Thu, Sep 27 2012
    Filed under: Beocord 5500
Page 1 of 2 (11 items) 1 2 Next > | More Search Options
Beoworld Security Certificate

SSL