Sign in   |  Join   |  Help

Search

  • Re: BM2000 fuses blow on amplifier board

    Hi Wilfried, Thank you for your fast reaction. As mentioned before powering on the BM results in more business for the parts shop: more fuses. Is it possible to check the no-signal current without the fuses in place? I can also remove the output IC's for testing although darlingtons behave differen from "normal " transistors" when put to a multimeter Aad
    Posted to The Workbench (Forum) by Aad Jansse on Tue, Feb 12 2019
  • Re: BM2000 fuses blow on amplifier board

    Darlingtons in place or detached from the pcboard? I have somewhere transistors, acquired as new, from a donor 2000 that was in working condition before it was scrapped. I will also check the speaker circuit. II will keep you posted Aad
    Posted to The Workbench (Forum) by Aad Jansse on Tue, Feb 12 2019
  • Re: BM2000 fuses blow on amplifier board

    Correction It = I
    Posted to The Workbench (Forum) by Aad Jansse on Tue, Feb 12 2019
  • Re: BM2000 fuses blow on amplifier board

    Disregard previous message ( : It )
    Posted to The Workbench (Forum) by Aad Jansse on Tue, Feb 12 2019
  • BM2000 fuses blow on amplifier board

    Playing some tapes on my newly "belted" BC1200 hooked up with the BM2000 the latter fell silent all of a sudden; after getting access to his"belly" I found 2 blown fuses, F102 and also F201 which one is depicted here. The other two fuses could have stand the current for the short moment that I had the power on. The question is, no surprise, what is the cause of the blowing and where to begin checking; it seems not so easy since I can not test with power on. As in all my previous
    Posted to The Workbench (Forum) by Aad Jansse on Sat, Feb 9 2019
  • Re: BC1200

    Finally, after checking several possibilities I noticed that the belt that runs through the plastic cup was weak ; awaiting a new belt to be supplied by Martin I took off the old one , cut out about 1 cm and glued the 2 ends together (ethylcyanoacrylaat by Pattex). (I also filled some cracks in the belt with this glue to avoid breaking later on.) After eliminating some rattling sounds ( one from having replaced wrong washers behind the clutch and the other from the tape counter) my old baby runs
    Posted to The Workbench (Forum) by Aad Jansse on Tue, Jan 29 2019
  • Re: Beocord 1600 R>R

    Sometimes one is put on the wrong track by searching in the wrong direction: after long time of "playing" with other B&O's I changed the 1600 from the living room with the 1200 from my "workbench", I discovered doing so that the problem was not so obvious: the "professionally" built cables to my amplifyer turned out to pass on only one channel. Problem easily solved. Aad
    Posted to The Workbench (Forum) by Aad Jansse on Tue, Jan 29 2019
  • Re: Bm 1200 lamps

    Hey Kristof , Do you have the complete schematics? If not I can send you a PM with copie of the relevant parts of the schematics and then we can see it from there if I can be of more help, although I am not an expert on these matters. Aad
    Posted to General Discussion & Questions (Forum) by Aad Jansse on Fri, Jan 25 2019
  • BM2000 fell silent

    leaning back and enjoying the music from my newly "belted" BG1200(R2R) via my white BM2000 I was cruelly set back to the real world by a loud "bang" from the speakers followed by an irritating silence. The not surprisingly asked question now is: where to start looking for the cause of the silent Master; the heatsink was not very warm. Aad
    Posted to The Workbench (Forum) by Aad Jansse on Tue, Jan 15 2019
  • Re: Beocord 1200 belts change

    Hasty conclusions: I did not notice that the hex screws are situated at an angle of 90 degrees instead of 180 degrees on the bushing'. The white plate came ealsily loose now, the next steps were no problem and the machine works smoothly now, however : when I stop rewinding a tape the left spool comes to an immediate stop but the right spool moves on 1 or 2 more rounds creating a problem when I subsequently activate the Play function: tape get stuck in the reel near the spindle. Is this a matter
    Posted to Vintage Products (Forum) by Aad Jansse on Sun, Jan 13 2019
Page 4 of 14 (134 items) « First ... < Previous 2 3 4 5 6 Next > ... Last » | More Search Options
Beoworld Security Certificate

SSL