Sign in   |  Join   |  Help

Search

  • Re: BV8-32 and ML/MCL converter

    It certainly does, although the comments allude to the BV8 speaker being overpowered rather than the external ones being under-powered. I definitely think its the latter because even with the centre function turned down as far as it will go there is simply no oomph getting to the CX50's they are acting like tweeters with no bass at all. The BV8 sound is very punchy so together on speaker 3 they are not bad, just nowhere near as good as the MX driving them with its own amp. Thanks for your reference
    Posted to General Discussion & Questions (Forum) by david707 on Sun, Jan 12 2020
  • Re: BV8-32 and ML/MCL converter

    Not at all.My MX4002 drove them brilliantly but this huge amplifier does nothing. There is no external gain adjust so perhaps I should assume there is a fault with it. It is a 50w/Channel amp but it seems more like 5w/channel
    Posted to General Discussion & Questions (Forum) by david707 on Sat, Jan 11 2020
  • Re: BV8-32 and ML/MCL converter

    Yes the Powerlink socket must be active because it is working but the volume is much too low on speaker 2 which is the external speakers. A comfortable listening volume for the TV in built speaker is around 30 but even at 50 the CX's are not properly driven. Perhaps there is a fault with the converter? I see no additional menus. The "centre" option appears in speaker 3 (when both TV and external speakers are in use) but there are no volume controls for the external speakers.
    Posted to General Discussion & Questions (Forum) by david707 on Sat, Jan 11 2020
  • BV8-32 and ML/MCL converter

    I am trying to use an ML/MCL converter to drive two CX50's from a Beovision 8. I have connected the two with a Powerlink Mk2 cable and it all works, but at very low volume on the CX50's. How do I change the (preset) volume of the amp? I have no ML connected as it's a standalone system.
    Posted to General Discussion & Questions (Forum) by david707 on Sat, Jan 11 2020
  • BV8-32 DVB-T Picture Format

    Two questions regarding the BV8, one is regarding picture format. Is there a way to store the format for the module because each time I have to press (DTV) format>go or format 3. It does not for some reason default to format 3 but there is no mention of any picture format settings in the guide book. Secondly is it possible to upgrade the TV software to the newer style black menus?
    Posted to General Discussion & Questions (Forum) by david707 on Mon, Jan 6 2020
  • Beovision 8-32 red tint to picture

    I recently inherited a BV8 32 but am generally disappointed in the picture quality particularly when compared to the BV8-40 which is superb. I have tried returning to factory settings to confirm if it has been changed but all parameters remain the same after the reset. The screen appears to have a pink/red tint which cannot be eliminated using the standard colour/contrast controls. The white test pattern shows up a reddish glow or 'warmth' which is not evident in the BV8-40. In the service
    Posted to General Discussion & Questions (Forum) by david707 on Fri, Jan 3 2020
  • Re: MX4002 V.Option 6

    Thanks for this Nick.Yes this LX does not make much of the familiar buzzing noise like the others on startup. It needs some attention and unfortunately the engineer was pushed for time that day so couldn't look at it. The MX is working fine but cumbersome to use because of the option 6 issue. Interestingly a BV8-32 which I have adopted operates just like the LX in option 6 even though it is an ML product. Regards David.
    Posted to General Discussion & Questions (Forum) by david707 on Sat, Dec 14 2019
  • MX4002 V.Option 6

    The LX4500 TV in V.opt 6 will respond to commands preceded by LINK. For some reason the MX4002 will not do this. It seems something in the software is different. I have tried all other V.option settings. Anyone know a way of doing this? There is no physical connection with the MCL (MCL2A only in the room)
    Posted to General Discussion & Questions (Forum) by david707 on Wed, Dec 11 2019
  • Re: MX4002 V.Option 6

    I thought that might be the issue Nick. I did have a 4000 and gave it to someone in need. Might have to do a swap. I have a Beolink video module. Might that 'switch' it into link mode by being connected and powered up? The LX4500 has unfortunately developed an intermittent picture problem. It varies from normal to darker to an "over exposed" look and also starting to show green/yellow areas wherever there is red in the picture. Regards David
    Posted to General Discussion & Questions (Forum) by david707 on Wed, Dec 11 2019
  • Re: Link Volume

    I will read with interest. I've tried out link mode but it doesn't really work for me because I have local sources attached to the scarts of the LX's in both link rooms - but it certainly makes things much better with a standalone link TV.
    Posted to General Discussion & Questions (Forum) by david707 on Mon, Nov 11 2019
Page 2 of 14 (139 items) < Previous 1 2 3 4 5 Next > ... Last ยป | More Search Options
Beoworld Security Certificate

SSL