Sign in   |  Join   |  Help

Search

  • Re: Beomaster 1500 no sound on one channel

    Thanks a lot!!! I sprayed the potentiometer and everything is ok!!! The scratching noise is gone and there is volume on both speakers!! If that didn't work and i had to replace the potentiometers i don't know if i could do it. What i saw when i opened it was a bit complicated. There were strings coming from the volume bar and end up in the potentiometer moving it back and forth. It doesn't seem like an easy job (or maybe it is if you' re experienced) So thanks again!!!!
    Posted to Vintage Products (Forum) by lamousis on Wed, Aug 14 2019
  • Re: Beomaster 1500 no sound on one channel

    Martin thanks! I've found a contact spray that i had (Teslanol lector clean) Should the contact spray has oil? isn' it dangerous? The volume potentiometer is this correct? Should i spray underneath it? Again sorry about the dump questions, i want to make sure i won't do something stupid and damage the bombaster...
    Posted to Vintage Products (Forum) by lamousis on Wed, Aug 14 2019
  • Re: Beomaster 1500 no sound on one channel

    Clean with water or with a contact cleaner spray? Or should i use a dust blower? If it come to replacing the volume potentiometer, is it simple, do i need a manual or something? Sorry for the too much questions, it's just that i have the Beomaster for about 40 years (and it's working ok except for that volume issue) and i don't want to do anything that would damage it... Thanks!!!!!
    Posted to Vintage Products (Forum) by lamousis on Mon, Aug 5 2019
  • Beomaster 1500 no sound on one channel

    Hello everyone I have a problem with an old Beomaster 1500 tuner/amplifier. When i try to turn up or down the volume it makes a scratchy noise and then the sound on one channel is gone (sometimes the left, sometimes the right). I have to turn the volume up and down many times to find a specific spot every time (in which the volume must be completely still) so that i can get sound on both channels Is there a way to fix this problem? Does anybody else have it? Thanks!
    Posted to Vintage Products (Forum) by lamousis on Mon, Aug 5 2019
Page 1 of 1 (4 items) | More Search Options
Beoworld Security Certificate

SSL