Sign in   |  Join   |  Help

Search

  • Re: Beovox M70 restored... step by step... well almost...

    I did the same speakers and used double sticky tape to put the grills back on. So far that has worked well. Jim.
    Posted to Vintage Products (Forum) by Jim Carr on Thu, Jan 10 2019
  • Re: M70 Speaker repair

    Thank you! I'm not sure how I missed your project but now I have the link and of course some questions I posted on it. I read Sorens M70 project but none of the pictures will load up the just say "picture not found". Not sure why. Thanks, Jim.
    Posted to The Workbench (Forum) by Jim Carr on Mon, Dec 10 2018
  • Re: Beovox M70 restored... step by step... well almost...

    Great job!! Now I have a few questions as I am doing some work on my 70's. Did you replace the foam on the front of the speaker? Did you epoxy all of the drivers? It looks like you have to remove the mid range driver from the inside and not touch the nuts you see on the front? How did you reattach the grills? Mine sound great now and I want to make sure they do for a long time. Thanks, Jim.
    Posted to Vintage Products (Forum) by Jim Carr on Mon, Dec 10 2018
  • Re: M70 Speaker repair

    Thank you! That is what I was looking for. Should I do this to all the speakers? The links talk about just the woofers and I read that some people were having trouble with the phase link speakers. Also I have some S60 speakers should I do those also? Thanks, Jim.
    Posted to The Workbench (Forum) by Jim Carr on Sun, Dec 9 2018
  • M70 Speaker repair

    Hi all! I bought a set of M70's and have been reading about the speaker magnets coming loose. All of my speakers sound good now and I have one grill off (they were glued on) and the speakers pass the finger test. Now I would like to do the epoxy prevention repair but cannot find a good procedure or pictures about doing it just mentions in different threads. Also a method of reattaching the grills. Thanks, Jim.
    Posted to The Workbench (Forum) by Jim Carr on Sat, Dec 8 2018
  • Re: Beovox M70 Mexico

    Just found this thread and it was an excellent read but the pictures are gone!! Do you know why?
    Posted to The Workbench (Forum) by Jim Carr on Fri, Dec 7 2018
  • Re: Re-fiting the top plate

    The top plate on my 4002 has always been touchy to get in place. I mostly find I have to move the sliding front a little until it drops in. I would not try to change any of the pins. One of mine looked bent so I straightened it a little and the plate would not go on. It turned out it was bent at the factory to fit.
    Posted to BeoGram (Forum) by Jim Carr on Mon, Oct 22 2018
  • 4002 tracking

    Hello out there! I am trying to get some tracking issues worked out with my 4002. I have a Hi Fi News test LP. I had my original MMC600 re done but seem to be having trouble setting it up. At 1.1 grams it will not pass any of the tracking bands. At 1.5 it will pass the first band (300HZ at 12db) I have checked balance, azimuth, parallel and stiction and all seem good. One thing I noticed is in a blank section on the LP with no groove just flat vinyl it will drift right as you are looking at it. My
    Posted to BeoGram (Forum) by Jim Carr on Sat, Mar 24 2018
  • Re: 4002 speed lights

    Steveric, Thanks for the info. My deck is a type 5503 from early 1974. I have ordered new led lights from Beolover. Sorry no extra guards. Jim.
    Posted to BeoGram (Forum) by Jim Carr on Sat, Mar 3 2018
  • 4002 speed lights

    Hi! Anyone know what and or where I can get a speed indicator light? There is only a part number in the manual.
    Posted to BeoGram (Forum) by Jim Carr on Tue, Feb 13 2018
Page 1 of 4 (40 items) 1 2 3 4 Next > | More Search Options
Beoworld Security Certificate

SSL