Sign in   |  Join   |  Help

Search

  • Beaomaster 1900 not switching to standby

    Hi, I have a Beomaster 1900 which has worked perfectly since replacing the bulbs and capacitor (as per Martin's kit). But now when I switch it on at the power switch, a lot of lights come on immediately (it doesn't go to standby). When I press on 'standby' there is a loud clicking noise somewhere beneath the power switch, but it refuses to go to standby and switches back on again. Any advice? Parts that can be replaced? I see my bass slider light is also off again so I will have to
    Posted to Beomaster & Beosound 5 Forum (Forum) by Henry on Sat, Mar 9 2019
    Filed under: Beaomster 1900 standby power
  • Re: Beomaster 1900 tape input

    Update: I pulled the male DIN plug out and hard wired the connections into the 1900. Using pin 2 as ground, I tested each of the other pins - only pin 5 produces nice clean sound, the other 3 pins are dead / very faint. I suspect the problem is with the 1900. Any advice? Thanks, Henry.
    Posted to Vintage Products (Forum) by Henry on Sat, Mar 12 2016
  • Re: Beomaster 1900 tape input

    Hi, Thanks for the prompt reply. I swapped the mp3 player to another amp (sansui), and the setup works fine, but not on the B&O. Ebay typically takes 6 weeks to arrive, plus I live in a very small town. Hence trying to wire it myself. Henry.
    Posted to Vintage Products (Forum) by Henry on Sat, Mar 12 2016
  • Beomaster 1900 tape input

    Hi, I need a wiring diagram for the 5 pin DIN connector for the TAPE input on the Beomaster 1900. I have wired a 3.5mm jack to a 5 pin male connector so that I can play music from a mp3 player through the amp. The phono and tuner sounds great, in stereo. But when I play through the Tape, left channel is virtually dead. I have tried to bend the pins in the female connector. No dice. I have swapped out cables and still no dice. So my assumption is I wired the DIN pins wrong or perhaps something then
    Posted to Vintage Products (Forum) by Henry on Sat, Mar 12 2016
  • Re: P30 tweeters dead

    Hi, sorry for the late reply, I am in South Africa. i am happy to go digging in there, nut I need some guidance as to what I am looking for. Thanks, Henry
    Posted to General Discussion & Questions (Forum) by Henry on Mon, Nov 2 2015
  • Beomaster 1900 treble and stereo

    Hi all, I have a Beomaster 1900 that is now after some weeks nearly perfect. I replaced the lamp kit and did some cosmetic repairs. It now switches on and both phono and the tuner work perfectly. The tape only plays on right channel, the left is there but very dim. Also the treble slider does not seem to change any tone anywhere, although the slider seems to work perfectly. Any suggestions? Thanks, Henry.
    Posted to Vintage Products (Forum) by Henry on Mon, Nov 2 2015
    Filed under: beomaster 1900
  • P30 tweeters dead

    Hi, I inherited two P30s from my dad and only fired them up for the first time in 15 years. They look ok but both tweeters are clearly dead. I opened them up but cannot find any obvious problems. I have limited electronical experience so don't want to fiddle too much without advice. Please help. Henry.
    Posted to General Discussion & Questions (Forum) by Henry on Sun, Oct 18 2015
  • Beomaster 3000-2

    Hi, I got a Beomaster 3000-2 In good condition. The 5 buttons on the far left were bent in by quite a lot as if it had been dropped. This meant that none of these buttons could be depressed and thus the speakers couldn't be switched on. I disassembled it and carefully clipped 6 wires to separate the face from the main unit. I took out the earphone jack unit and managed to get in a clamp and bent the metal clip back. I reassembled and resoldered. Fantastic! Everything worked and sounded great
    Posted to General Discussion & Questions (Forum) by Henry on Sun, Oct 18 2015
  • Salvaged from a B&O avant

    Hi all, Salvaged these speakers x2 and dedicated amplifiers from an old B&O TV. Hooked up the speakers and they sound great. What can I do with the amps? Are they worth integrating into something new? Thanks, Henry.
    Posted to General Discussion & Questions (Forum) by Henry on Fri, Oct 9 2015
  • Re: Beomaster 1900 lamps

    Hi Ben, What is your email address? I am henrygreyling@gmail.com Thanks.
    Posted to General Discussion & Questions (Forum) by Henry on Fri, Sep 18 2015
Page 1 of 2 (15 items) 1 2 Next > | More Search Options
Beoworld Security Certificate

SSL