Sign in   |  Join   |  Help

Search

  • Re: Beogram 8000 on the way...

    That could be a problem, though it did work and play when it first arrived and I haven't found any broken bits yet. Hmm, the service manual only shows me the exploded diagram and I can't quite make out the details. Here's a pic of the underside of the assembly. What are the forks made of? Metal, plastic? Cheers
    Posted to BeoGram (Forum) by etype76 on Wed, Sep 16 2015
  • Re: Beogram 8000 on the way...

    Cheers, it won't win any beauty contests but the joints seem stable. As you can see, Capacitor C28 will sit a bit high, I wanted it closer to the board, butI'd spent so long on recapping it I thought it would do. I also thought, If i need to back to it it will be easier to remove. Here's a pic of the tonearm spindle I took a few days ago, can anyone tell me what the plastic thing on the spindle is, and where it should go? I realise now that the tonearm assembly wasn't correctly in
    Posted to BeoGram (Forum) by etype76 on Wed, Sep 16 2015
  • Re: Beogram 8000 on the way...

    Slow progress today, I have replaced the capacitor in the CPU box. This one is very tricky, soldered on both sides of the board and perilously close the microprocessor. It is also confusing for someone who is simply 'removing parts and replacing them'; this one threw up a couple of issues. The capacitor seemed to have a red and blue wire going from it. it's such a confined space, it's hard to tell. Anyway, I desoldered these two wires to the new capacitor pins and then inserted the
    Posted to BeoGram (Forum) by etype76 on Wed, Sep 16 2015
  • Re: Beogram 8000 on the way...

    Yes, you're right, the hum is the motor trying to push the tonearm forward beyond the spindle. Plugged in again today and it hasn't gone back to its rest. A transformer bringing it to 100v made no difference either. I bought a digital multimeter, have never used one before but I guess I'll need it to start trouble shooting. I need a break from it today, maybe I'll find some time tomorrow to get it back into the service position. I really want to get this thing up and working in the
    Posted to BeoGram (Forum) by etype76 on Mon, Sep 21 2015
  • Re: Beogram 8000 on the way...

    Yeah, I knew in my gut I shouldn't have put it all together. Strange, I've just plugged it in again and it's behaving better. 1. Red standby dot displays 2. Turn does not function. 3. When 45 is pressed it displays 45.00 4. When 33 is pressed it displays 33.33 5. when I press play, the platter turns and the tonearm moves a cm and the light comes on, then the display goes completely blank. Actually, the machine is not behaving so differently than when it arrived. Although, the + - buttons
    Posted to BeoGram (Forum) by etype76 on Sun, Sep 20 2015
  • Re: Beogram 8000 on the way...

    I plugged it in and disappointingly though not entirely surprisingly there seems to be a fault. The display flashes 33.33 intermittently and then goes completely blank, it switches to 45;00 when I hit the 45 button. the platter spins automatically. There seems to be no life from the tonearm at all. I guess I'll have to open it up again...urghh. Thanks
    Posted to BeoGram (Forum) by etype76 on Sun, Sep 20 2015
  • Re: Beogram 8000 on the way...

    So, that's everything done. Just one thing, in Martin's kit there is a 2,2uf spare. There's a note '2,2uf - Mount Radial or Axial type according to the original. but I have this spare 2,2uf radial now. I've gone over the chart and everything seems to be in place. Anyway, what would you say is the next step? Here are two pics of the board, from both sides; Thanks
    Posted to BeoGram (Forum) by etype76 on Sun, Sep 20 2015
  • Re: Beogram 8000 on the way...

    Great, those pics are very clear, thanks. Here's what I did, This is what you meant by soldering the negative pin to the metal base, right? I detached the metal ring from the old 2200uf cap with needle-nose pliers and place it around the new one, just bending the positive pin towards centre and 'curling' the negative pin around the metal ring. I held it in place with a blob of blu-tak and soldered the pin. Then I place the positive pin in the centre hole and the 3 other negative pins
    Posted to BeoGram (Forum) by etype76 on Sun, Sep 20 2015
  • Re: Beogram 8000 on the way...

    Pretty good progress today, I have soldered all but one (the largest 2200uf / 63v) capacitor. I also managed to reflow/resolder all the joints near the connectors, basically the areas marked red on Martin's cap location chart. The second largest cap of the same value was an odd thing, on the trace side, C24. The lines indicating where the cap was and the holes were filled with solder but the actual pins were through two other holes next to them. The polarity was also different from that marked
    Posted to BeoGram (Forum) by etype76 on Sat, Sep 19 2015
  • Re: Beogram 8000 on the way...

    Yes, thank you! it was attached to the rear shaft, really out of the way with the forks pointing to the back of the unit, luckily, they're in tact. I think I've fitted back on correctly now and the whole assembly is under the tonearm lid once again. I decided to plug the unit in, the red dot on the display lit up and the inner platter rotated, I heard the tonearm servo. I unplugged it as I didn't want to cause (further) damage. Not sure what this means but I'll continue with the recap
    Posted to BeoGram (Forum) by etype76 on Thu, Sep 17 2015
Page 1 of 8 (74 items) 1 2 3 4 5 Next > ... Last ยป | More Search Options
Beoworld Security Certificate

SSL