Sign in   |  Join   |  Help

Search

  • Re: Adjusting the plater height on BeoGram 4002

    Thank you for this. Yes I see the screw with the locking nut. I have the same thing except that my screws have no slot on the top for the screw driver. Never seen this in the manuals of videos. just don't know what to do next
    Posted to BeoGram (Forum) by RobM on Tue, Mar 2 2021
  • Re: TX2 sound issues

    I figured it out! Seems my connection from the turntable to the Phono Amp wasn't good. Had some connectors allowing me to plug in two sets of RCA jacks. This was bad. I removed the connectors and all is good now! Thanks again!
    Posted to General Discussion & Questions (Forum) by RobM on Mon, Mar 1 2021
  • Re: TX2 sound issues

    I figured it out! Seems my connection from the turntable to the Phono Amp wasn't good. Had some connectors allowing me to plug in two sets of RCA jacks. This was bad. I removed the connectors and all is good now! Thanks again!
    Posted to General Discussion & Questions (Forum) by RobM on Mon, Mar 1 2021
  • Adjusting the plater height on BeoGram 4002

    I would like to raise the plater to make it flush with surrounding surface. Watched a video demonstrating a technique used on the BeoGram 4000 where 3 screws are adjusted on the suspension. But my 4002 lacks these screws and has tree bolts that hold the suspension in place. Am I missing something?
    Posted to BeoGram (Forum) by RobM on Mon, Mar 1 2021
  • Re: TX2 sound issues

    Thanks! I will check out the second option looking at the picture. do you happen to know the procedure for making that adjustment?
    Posted to General Discussion & Questions (Forum) by RobM on Wed, Feb 24 2021
  • Re: TX2 sound issues

    I tried to upload pics but suffice it to say that my pics look identical to yours. I see nothing "wrong". What should I be looking for and what do I do if adjustment in necessary. The cracked wires in the tonearm are beyond my capabilities. Any advice would be most appreciated. Thanks! Rob
    Posted to General Discussion & Questions (Forum) by RobM on Wed, Feb 24 2021
  • Re: TX2 sound issues

    OK thanks!
    Posted to General Discussion & Questions (Forum) by RobM on Wed, Feb 24 2021
  • Re: TX2 sound issues

    Excellent question. I’ll check tonight
    Posted to General Discussion & Questions (Forum) by RobM on Tue, Feb 23 2021
  • Re: TX2 sound issues

    Well, Strangely it did seem to have some of that missing music but it sounded "fuzzy" definitely still pretty messed up.
    Posted to General Discussion & Questions (Forum) by RobM on Tue, Feb 23 2021
  • TX2 sound issues

    Happy Siunday! or Monday depending on where you live! Yesterday my TX2 started sounding strange - on 33rpm. the sound seemed like it was missing the music from the other channel - but both channels were working! I tried a 45 record on 45rpm and it sounded fine. I thought maybe receiver issues (Beombaster 6000) but it plays other inputs through both DIN and RCA jacks just fine. I also switched from my mmc3 to my rebuilt mmc4 cartridge and same issue... Does anyone have even the faintest idea what
    Posted to General Discussion & Questions (Forum) by RobM on Mon, Feb 22 2021
    Filed under: TX2 sound issues
Page 1 of 4 (31 items) 1 2 3 4 Next > | More Search Options
Beoworld Security Certificate

SSL