Beolab 5 – Help needed

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Home Forums Product Discussion & Questions BeoLab Beolab 5 – Help needed

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #42731
    YannChris
    GOLD Member
      • Brittany, France
      • Topics Started 27
      • Total Posts 257

      Hello Beoworlders,

      One of my BL5 does not activate when I switch-on a source.

      The red light is on and flashes when I tap the tactile area.

      Power cycle does not change anything.

      Is there a way to hard-reset the speaker?

      I have been told that BL5 cannot be fixed anymore by dealers and that chassis have to be sent to Struer for repair (with no idea of delay).

      I am very surprised with this, can anybody confirm?

      Thanks by advance and kind regards,

      Yann.

       

       

      #42732
      Mr10Percent
      BRONZE Member
        • Topics Started 9
        • Total Posts 511

        Hi,

        sorry to be a bearer of bad news, but one of the possibilities of this type of behaviour may be a problem with the EPROM/ chassis module.

        Did the failure occur after playing very loud or bassy music? If so, the fault could be overheating, but then not resetting itself.

        Have you also tried doing a room calibration? That may “wake” the unit up??

        Best of luck

        #42733
        YannChris
        GOLD Member
          • Brittany, France
          • Topics Started 27
          • Total Posts 257

          Hi,

          Thanks for your reply.

          Yesterday I watched TV at normal level, the failure occured today when I switched-on the TV.

          Nothing happpens when I do a room calibration.

          Yann?

          #42734
          Donot
          BRONZE Member
            • Usa
            • Topics Started 0
            • Total Posts 2

            Do you have check the cables?

            if the red light is on than must your cable not have connected, or have you change the menu audio ?

            if you lab 5 is defect than blinking the red light,

            hardreset is press ca 20 sec the key at the top
            you can also unplug the speaker for 5 minutes

            hardreset delete also your calibration details

            #42735
            YannChris
            GOLD Member
              • Brittany, France
              • Topics Started 27
              • Total Posts 257

              Thanks Donot,

              Yes, I checked the cables and no, I didn’t change anything in the menu.

              The red light is solid. It only blinks if I touch the tactile zone.

              I performed the hard reset:  the red light blinked as long as I touch the tactile zone. After a moment, it stopped blinking.

              Then performed a power-cycle.

              Nothing changed.

              I come to the conclusion that the Lab5 is faulty and my question about the repair process makes sense.

              Can anybody confirm, or inform, that chassis have now to be sent to Struer for repair (with no indication of delay…)?

              Kind regards,

              Yann.

               

              #42736
              Donot
              BRONZE Member
                • Usa
                • Topics Started 0
                • Total Posts 2

                Call your local B&O dealer

                hi have laptop and cable to look inside the software about the lab5.

                it is possible that the software it indicates what is defective.

                repair is only possible by a dealer, you cannot send it yourself, at my cost repair 900 euros by exchanging the chassis (the amplifiers) it seems that b&o has now opted for repair, so your chassis is now being tested and the parts dell replace one that is defective, this reduces the starting price to at least 500 euros.

                #42737
                YannChris
                GOLD Member
                  • Brittany, France
                  • Topics Started 27
                  • Total Posts 257

                  Thank you, Donot.

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.

                Home Forums Product Discussion & Questions BeoLab Beolab 5 – Help needed

                • You must be logged in to create new topics.