Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the The Workbench forum. See all tags in the site
  • Beocenter 9500 tape deck squeaking noise and transformer humming noise

    Dear all, I'm new to the forum but I've already learned a lot here and have to thank you for that! I have two Beocenters 9500. I own the first one since round about 2000 when I bought it used. It allways worked very wel,l aside from the tape deck which i rarly use, since last December. Then the...
    Posted to The Workbench (Forum) by Motorman on Wed, Jan 13 2021
    Filed under: Beocenter 9500, noise, cassette, repairs, BC9500, tape deck, loud noise, tape
  • Beocord 3300 belt and motor pulley

    Is this damaged? Can anyone tell me? I finally removed and cleaned up all of the remaining gummy belts for replacement. There appears what might be either remaining drive belt from the motor or a damaged damper of some sort. I'm not able to tell from the service information. If it's damaged I...
    Posted to The Workbench (Forum) by evereddie on Wed, Dec 23 2020
    Filed under: Repair, service, belt, repairs, Beocord 3300, Beocord, tape belt, tape deck
  • Beocord 1900 Refurbishment - help needed!

    Hi I'm refurbishing a Beocord 1900 and have just managed to get it powered up again now However it is missing 2 pus buttons for REC and PLAY and PAUSE is part broken Any idea where I might source these from please? Also on play it is currently quite slow and muted - sounds like maybe a head clean...
    Posted to The Workbench (Forum) by mgwynn1 on Wed, Jun 10 2020
    Filed under: tape deck, tape, tape head, tapehead, Beocord1900, beocord 1900
  • Beocord 1900 Refurbishment - help needed!

    Hi I'm refurbishing a Beocord 1900 and have just managed to get it powered up again now However it is missing 2 pus buttons for REC and PLAY and PAUSE is part broken Any idea where I might source these from please? Also on play it is currently quite slow and muted - sounds like maybe a head clean...
    Posted to The Workbench (Forum) by mgwynn1 on Wed, Jun 10 2020
    Filed under: tape deck, tape, tape head, tapehead, Beocord1900, beocord 1900
  • Beosound Ouverture (2500) - Tape deck issue

    Hello, I am new at this forum. I was hoping that I could find some help regarding my "new" Beosound Ouverture. My current issue: Tape deck starts playing my tape for about 3 seconds, then it stops. While playing for those 3 seconds, the music sounds like it's slowed down. I have just exchanged...
    Posted to The Workbench (Forum) by ethereal on Wed, Sep 18 2019
    Filed under: 2500, Ouverture, tape deck, tape, deck, beosound
  • Beocord 2400 Tape Deck - One Channel Dead - Advice

    Hello all! I wanted to pick your brains about a tape deck I have, the Beocord 2400: https://www.beoworld.org/prod_details.asp?pid=945 Firstly, I've been able to fix one thing. The playback/record switch was definitely dirty. I used Deoxit and worked the heck out of it. As a result, the right channel...
    Posted to The Workbench (Forum) by AB on Tue, Aug 1 2017
    Filed under: Repair, volume, cassette, playing, repairs, Beocord 2400 Left Channel Dead, Beocord 2400, sound, Beocord, tape deck, poor sound, vu meter, tape, bc2400, channel, vu, tape head, tapehead, Beocord1900
  • Beocenter 9000 Tape issue (fully functional but no sound)

    Hi! After a few years lack of use the tape deck of our BC9000 produces no sound at all. I have checked the tape pulleys and capstans which work perfectly. There are no visible curls on the tape. There is no sound from either channel in tape mode. Not even static or any other noise from a poor connection...
    Posted to The Workbench (Forum) by kammeri on Sat, Oct 15 2016
    Filed under: beocenter 9000, tape deck
  • Beocord 4500

    Hi, I just got my hands on Beocord 4500, I knew it has a problem, but it wasn't what I expected. When I "push" the play, drive shafts starts spinning correctly, so the belt is in a good condition (checked), but the motor, which should spin cassette reels doesn't work correctly. It spins...
    Posted to The Workbench (Forum) by jrtv on Sat, Sep 4 2021
    Filed under: Beocord 4500, #Beocord 4500 #C-tape #cassette, tape deck, #repair, help needed!
Page 1 of 1 (8 items)
Beoworld Security Certificate

SSL