Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the General Discussion & Questions forum. See all tags in the site
  • BeoLab 14 subwoofer dead -- spare part no longer available

    I live in Hong Kong. My BeoLab 14 Subwoofer recently failed to switch on (lamp does not light up). Official dealer's technician visited and said one of the two IC boards is not working. However, they no longer have this spare part available and basically said "Sorry, we can't help"...
    Posted to General Discussion & Questions (Forum) by Kirin Ichiban on Sat, Apr 24 2021
    Filed under: Beolab, subwoofer, beolab 14
  • No surround sound or sound through subwoofer

    I have a BV8 with four speakers connected - 2 x BL8000's in front and 2 x BL6000's in rear and a BL19 subwoofer. I mainly play music through iTunes (lossless) and watch movies on either DVD or mainly Netflix or free to air TV. I notice that there seems to be almost nothing coming out of either...
    Posted to General Discussion & Questions (Forum) by paddy2042 on Sun, Feb 7 2021
    Filed under: Surround Sound, subwoofer, rear speakers
  • Beocenter 2 CTRL Socket

    Hi everyone, does someone know about the functionality of the Ctrl socket on the Beocenter 2? Is it an input or an output? Could it be used to trigger on/off an (off brand) active subwoofer for example or is it only for receiving IR signals? The manual only says that it is neccesary to connect it when...
    Posted to General Discussion & Questions (Forum) by beoboehm on Sat, May 2 2020
    Filed under: Beocenter 2, subwoofer, Beo Center 2, CTRL
  • Poor bass from beolab 19- help me!

    I recently bought a set of bl 17, bl 18 and a bl 19 to handle the bass. It is connected to my beolab transmitter 1, via WISA ( I WANT NO WIRES) The beolab transmitter 1 is connected to my lg oled c7 via toslink. I tried resetting the transmitter several times, adjusting the speakers (W/F/C) , with and...
    Posted to General Discussion & Questions (Forum) by Kjaerslund on Fri, Sep 6 2019
    Filed under: Beolab, subwoofer, beolab19, 19, bl19
  • Beomaster 5000 type 2323 incessant hum between tracks, & prob connecting powered sub

    I have two issues and any help would be much appreciated and to give the full landscape of the system, I am using the following equipment elements: Beomaster 5000 (type 2323) with Master Ctl Pnl 5000, both represented as "tested by a professional" and seem to work fine. Speakers: early 90's...
    Posted to General Discussion & Questions (Forum) by Michael on Mon, Aug 20 2018
    Filed under: subwoofer, hum, humming sound, white noise, strange noise, Beomaster 5000
  • Beolab 9 frequency response

    The B&O service manual quotes 30-20.000Hz on the Beolab 9. However I can´t seem to find a reliable source for the regarding "method" they use to get this data. Is this +/-3db ? I have a Bowers&Wilkins ASW610 Subwoofer which goes down to 27Hz at +/-3db and 20Hz at +/-6db If the...
    Posted to General Discussion & Questions (Forum) by Lennart25 on Sat, Dec 2 2017
    Filed under: Beolab 9, subwoofer, bass, specs, frequency response, technical, bowers wilkins, effective frequency range
  • Beolab 2 and Beovision 14

    Hi everyone, I have recently upgraded to a Beovision 14 and my current set up consists of two beolab 8000's two Beolab 9's and a Beolab 2 subwoofer. Since upgrading my TV system from the Beovision 10 my speaker system isn't what it used to be and the Subwoofer especially is very lacklustre...
    Posted to General Discussion & Questions (Forum) by Jameo35 on Thu, Jan 5 2017
    Filed under: subwoofer, Beolab 2, Beovision 14
  • Beolab 2 - leakage around connection panel

    Hi, I recently got the Beolab 2 to give a little more punch to my set up with the classic Beosound 9000 and a pair of Beolab 8000. At lower volumes I love this combination! My issue is at higher volumes: There seems to be some leakages around the connection panel at the back. The seal for the speaker...
    Posted to General Discussion & Questions (Forum) by j_a_s on Wed, Jul 13 2016
    Filed under: noise, subwoofer, Beolab 2
  • Beolab 2 troubleshooting....

    My trusty BL2 (about 7-8 years old - not a ton of use, never any abuse) is no longer "clicking" on.... It is plugged in and the "red light" is on.... when I plug/unplug the relay and green light will click for a sec and then turn red - but no sound. I have tried various configurations...
    Posted to General Discussion & Questions (Forum) by mfirst on Sat, Jun 18 2016
    Filed under: troubles, subwoofer, Beolab 2
  • Beolab 6000, 8000 and/or subwoofers

    Hello I am new to the forum and have some questions about speakers. I have read around 10 threads about BL 6000/8000 as well as the articles about each product but that probably made me more confused than before… Originally my plan was to buy a pair of BL6000 but after reading up a bit in this...
    Posted to General Discussion & Questions (Forum) by lg on Sun, Dec 20 2015
    Filed under: Beolab 6000, Beolab 8000, subwoofer, Beolab 8002, beolab 6002, beolab 8000 Mk2
Page 1 of 2 (16 items) 1 2 Next >
Beoworld Security Certificate

SSL