Sign in   |  Join   |  Help
All Tags » noise (RSS)

Browse Forum Posts by Tags

Showing related tags and posts for the Vintage Products forum. See all tags in the site
  • Beocenter 9000 - restoration

    Hello, I am a happy owner of a Beocenter 9000 purchased ca. 1986. After so many years, It's starting to show its age: (i) lower glass panel getting loose (the glue has dried), (ii) some parts of the display (upper glass panel) don't lit until I tap on it, (iii) some CD's (specially those...
    Posted to Vintage Products (Forum) by objectifnul on Tue, Nov 6 2018
    Filed under: beocenter 9000, Beocenter, noise, Hum, Restoration, cassette, rumble, playback
  • Beocenter 4000 type 1603 output stage voltage

    Hi All, Just wondering if anyone can help at all, I am in the process of restoring a Beocenter 4000 type 1603. I have recapped the amps and psu with new caps and its been reccomended I change the pots on the output stages I have some on order but I cannot seem to find on my circuit drawings what the...
    Posted to Vintage Products (Forum) by Lewis T on Thu, Jan 25 2018
    Filed under: speaker sets, repair, help, Beocenter, vintage, noise, becenter, refurb, Classic Audio, speaker channel, DIN, cover, amp, amplifier, beocenter 4000, old, 4000, Service Manual, how to, potentiometer, Hifi, channel lost, repair., output
  • RX2 rubbing/scraping sound

    So, decided to break out the RX2 and swap cartridges with the TX2. Undid the 3 transit screws according to the directions on the archived forum here. Put lp on, pressed play and everything seems to work but there is a scrapping, rubbing sound from the platter area...thoughts?
    Posted to Vintage Products (Forum) by starkiller on Sat, Sep 24 2016
    Filed under: noise, platter, Rx2
  • There's smoke coming out of my Beomaster 1000. Help.

    I have no experience working with electronics at all. I recently acquired a Beomaster 1000 from my elderly neighbours as they were clearing out their garage. I hooked it up via a 5 pin din - phono cable to my iPod and then via two 2 pin din stereo cables to a pair of Mordaunt Short Pageant II speakers...
    Posted to Vintage Products (Forum) by Clocktopi on Sun, Sep 6 2015
    Filed under: speaker sets, repair, speakers, muffled sound, vintage, noise, wire, DIN, speaker, volume, beomaster, Restoration
  • Beocenter 4000 1978 - 1980 version - no speaker output - Help!!!

    Hi Everyone, I just wanted to ask if anyone knows what could be wrong with my Beocenter 4000 I was listening to it this morning all was fine, I changed one of the fm presets and pushed the popup part back down that lives under the chrome flap on the top of the unit it was working fine and sounded great...
    Posted to Vintage Products (Forum) by Lewis T on Wed, Dec 25 2013
    Filed under: repair, Beocenter, failure, speakers, vintage, noise, becenter, Classic Audio, speaker channel, speaker, volume problem, volume, amplifier, vintage., beocenter 4000
  • Beocenter 7002 vinyl problems

    Hello I have a Beocenter 7002 which I use daily both to play records and listen to the radio. I am getting some scratchiness/inteference from the speakers but only when I play records, the radio is fine. I have checked the connections on the original B&O speakers and on the Center but they all look...
    Posted to Vintage Products (Forum) by redrovery on Thu, Jan 3 2013
    Filed under: Phono, speakers, vintage, noise, stylus, becenter, catridge
  • Beomaster 3300 "hum" noise only ...

    Hello all, I have a Beomaster 3300 that the last 2-3 weeks, outputs only a "hum" noise when it's turned on. This noise is the same in every volume level and is the same on both speakers. Goes away only on muting. Sometimes after some minutes the bad noise goes away and the beomaster plays...
    Posted to Vintage Products (Forum) by anagnost on Sun, Dec 9 2012
    Filed under: beomaster 3300, noise
Page 1 of 1 (7 items)
Beoworld Security Certificate

SSL