Sign in   |  Join   |  Help
Click here to change your Beoworld Account Details

Browse Forum Posts by Tags

Showing related tags and posts for the Forums application. See all tags in the site
  • Beomaster 3000-2: Left Channel Dead

    Hi, this is my first B&o product and my first post on this forum. I should mention that I don't have much experience tweaking with audio equipment but have repaired some computer components in the past. I bought this receiver purely for its aesthetics - I just couldn't help myself. When I...
    Posted to The Workbench (Forum) by junius on Thu, May 24 2012
    Filed under: Vintage Beomaster, Beomaster, Beomaster 3000-2, Dead Channel
  • Stuck in phono mode Beomaster 1900

    Greetings all. Total beo virgin here. Just picked up my first. A Beomaster 1900. All was swell until powered up this morning. Standby came on. Pushed FM 5. Phono light came on in addition to FM 5. Unit was now in phono mode. Every other mode pushed came on but phono light remained on and kept unit in...
    Posted to The Workbench (Forum) by 2amp on Tue, Feb 26 2013
    Filed under: Beomaster
  • Beogram 6000 and Beovox s-45 / RL45 (or 60)

    Hi everybody. I recently acquired a Beogram 6000 in perfect condition and wanted to couple it up with one of my loudspeaker sets. I have a couple of Beovox S45 and a couple of Beovox RL45 or RL 60 (I can't remember right now). Anyway, I was wondering what the right choice concerning amp would be...
    Posted to BeoGram (Forum) by devilfred on Mon, Mar 11 2013
    Filed under: amp, beomaster, beovox s45, beogram 6000, beovox RL
  • Beomaster 6500 geen stand-by led

    Hallo Allemaal, Wie kan mij een beetje op weg helpen. Ik heb een Beomaster 6500 die nadat ik deze aansloot enkele minuten heeft gespeeld. Ik heb tijdens het spelen met een beolink 7000 nog de datum en tijd ingesteld. Tijdens dit vastleggen knipperde de stand-by led, dit is mogelijk normaal. Twee weg...
    Posted to BeoWorld Dutch (Forum) by Leonardo on Wed, Apr 3 2013
    Filed under: bm, beomaster, 7000, 6500, standby led
  • Beolab 1700 amp running really hot?

    Hi Everyone, I have just brought a Beolab 1700 amp and tuner along with the beocord 2200 its all in really good condition. All i know about it is that it was found in a loft. The issues seem to be with the amp only. When using it the heat sink gets so hot you cant even touch it, is this normal ? The...
    Posted to Vintage Products (Forum) by Lewis T on Tue, May 14 2013
    Filed under: beolab 1700, beomaster, vintage., beolab
  • Beomaster 900 - dead in the water

    Hi, Bought a beautiful BM900 in almost perfect working order except for a cracked front dial. Whilst I was dismantling the unit, waiting for the dial to arrive from Dillen, I started checking and replacing the electrolytics. Long story short, reassembled, plugged in, nothing......... Everything lights...
    Posted to Vintage Products (Forum) by Duncan Jones on Fri, May 17 2013
    Filed under: beomaster, BM900
  • Beosound 5, Beosound 9000 and Spotify....frustration with an unreliable, unstable system.

    OMG! B & 0, please! Spotify requires master mode on the Beosound 5. I have suffered through the inconvenience and expense of multiple service calls related to lockups in my integrated system of B & O products at a vacation property (Miami Beach) I own that is remote from where I spend most of...
    Posted to General Discussion & Questions (Forum) by R E Pruitt on Fri, May 17 2013
    Filed under: Masterlink Gateway, BEOSound 9000, spotify, BeoSound 5, Beomaster, firmware
  • beomster 6500 vs 5500

    HI all I'm new to this forum and B and O in general. My father has an RX2 that I am getting repaired for him and started looking at B and O and fell in love with it. I got a Beomaster 6500 on Ebay a while back and I'm absolutely blown away at how good it sounds. I've been bitten by the bug...
    Posted to Vintage Products (Forum) by Echodog on Tue, Jun 4 2013
    Filed under: beomaster
  • Beomaster 4400 on off switch

    Hi all I have obtained this lovery amp and besides one duff output stage and a re capp required the on off sw is faulty it will not lock down. It lools like the plastic has worn a way ( the sw works you have to hold the sw down ) and it is the sw at fault as its in bits on the bench !!!!! So my question...
    Posted to The Workbench (Forum) by Printerman2012 on Fri, Jun 7 2013
    Filed under: Beomaster
  • Beomaster 8000 after (probably successful) recapping: adjustments?

    Hi everyone! Yesterday I had a crazy recapping session through all my Beomaster 8000 (except the capacitor under the CPU cover, I didn't trust myself to open that). Cap kit from Martin, of course! :) I put it together again after some suspence moments (no display at first, because I didn't reconnect...
    Posted to The Workbench (Forum) by mscili on Fri, Jul 19 2013
    Filed under: Beomaster, beomaster 8000 output stage servicing
Page 1 of 6 (51 items) 1 2 3 4 5 Next > ... Last »
Beoworld Security Certificate

SSL