Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the The Workbench forum. See all tags in the site
  • Beomaster 2400 - Installing front control touch panel

    Hey all. I'm having issues getting the front control touch panel to work correctly after taking it apart. I'm not sure how the copper fingers should lay down on something or fit into something. I've tried just lining up the top groves and bottom groves of the panel and none of the touch controls...
    Posted to The Workbench (Forum) by GuyHanson19 on Thu, Nov 26 2020
    Filed under: beomaster 2400, #repair
  • Volume indicator lamps

    An other/another request for help this time. I got a Beomaster 2400 this week, good sound, but a few incandescent lamps were broken and by now replaced. Tuning is OK, volume control up and down soundwise also OK, but even after mounting new bulps, they are not shining. Do I have to look for a culprit...
    Posted to The Workbench (Forum) by Aad Jansse on Wed, Mar 4 2020
    Filed under: beomaster 2400
  • Re: Beomaster 1900 amplifier issues

    Bit late with the answer, but i had the same issue on my 2400. Standby when powered on. Pulled left outout tranny. Startup now OK and played fine in the right channel only. Had recapped and swapped all trannies in the output stage left channel, except for the output tranny as it measured out fine. Swapped...
    Posted to The Workbench (Forum) by jesperb on Tue, Jul 2 2019
    Filed under: Beomaster 1900, beomaster 2400, beomaster 1900-2
  • Re: First attempt at Beomaster 2400 'refurbishing'

    I thinks this project is almost done. Did a FM tuner check yesterday, reception is surprisingly good, with only a short length of 0.75mm2 wire pushed into the antenna plug Only headphone hum left to fix. Tried two different jack-to-mini-jack converters and 3 different headphone types so an issue with...
    Posted to The Workbench (Forum) by jesperb on Tue, Apr 9 2019
    Filed under: Beomaster 1900, beomaster 2400, hum, beomaster 1900-2
  • Re: First attempt at Beomaster 2400 'refurbishing'

    Got a little spare time, which immediately went into the Beomaster 2400 on the kitchen dining-room workbench (no room for guests this week). Looking at the 'volume up mute' issue, where volume would play briefly and then mute for the first 3-4 taps on 'vol up', I measured out 'any...
    Posted to The Workbench (Forum) by jesperb on Sat, Apr 6 2019
    Filed under: Beomaster 1900, beomaster 2400, beomaster 1900-2
  • Re: First attempt at Beomaster 2400 'refurbishing'

    Just as soon as i got the lid back on, new issue : Sometimes the sound mutes, when i turn the volume up. Only if i touch volume up shortly, like nudging a single step up in volume. Keeping the finger on volume up and it works just fine. Volume down doesn't have this issue, at least i have not been...
    Posted to The Workbench (Forum) by jesperb on Wed, Mar 13 2019
    Filed under: volume, beomaster 2400, beomaster 1900-2, Beomaster 1900 Beogram 1500
  • Re: First attempt at Beomaster 2400 'refurbishing'

    After some deliberation, I turned the Beomaster on. It turned itself off immediately and gave a blue puff of smoke. Plus one of the 220VAC fuses blown. Finally i did, what Dillen has told me (and many others) to do from the start : Test/measure all components in the output stage. Nothing seemed to be...
    Posted to The Workbench (Forum) by jesperb on Thu, Mar 7 2019
    Filed under: Beomaster 1900, beomaster 2400, beomaster 1900-2
  • Re: First attempt at Beomaster 2400 'refurbishing'

    Finally got some spare time and got the 2400 out of the closet. Pulled the cooling fans off the output transistors and desoldered them all (IC200,201,300,301). Actually a lot easier than i would have thought, lesson learned. First one (IC200) came out in two parts, see the picture below and the Peak...
    Posted to The Workbench (Forum) by jesperb on Sat, Mar 2 2019
    Filed under: Beomaster 1900, beomaster 2400, beomaster 1900-2, standby
  • First attempt at Beomaster 2400 'refurbishing'

    Hello All, Starting my first real repair project on a Beomaster 2400 - no previous BeoFixing experience, but lots of electronic DIY. This model came from my Dad, which is why i said yes to try to fix it, besides always having wanted to having fixed a Beomaster by myself (counting on a little help from...
    Posted to The Workbench (Forum) by jesperb on Thu, Apr 26 2018
    Filed under: Beomaster 1900, capacitors, beomaster 2400, Beomaster control panel lamps, supply voltage, beomaster 1900-2, poor sound
  • Beomaster 2400-2 15volt transistor runs hot

    After a complete recap and cleaning (and a lightbulb kit from Martin) i find that TR27, the 15 Volt regulator runs very hot, at least i think its to hot, you can barely hold the heatsink. Is this normal or should i go looking for signs of trouble? And if so, where should i start? Thanks in advance, Marc
    Posted to The Workbench (Forum) by marc on Fri, Jan 6 2017
    Filed under: beomaster 2400, hot heatsink, tr27, transistor 27
Page 1 of 2 (13 items) 1 2 Next >
Beoworld Security Certificate

SSL