Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the Vintage Products forum. See all tags in the site
  • Beomaster 1900 broken tape input

    Hi, I just bought a beautiful BeoMaster 1900, all the sliders, buttons and light bulbs works like a charm, the FM radio gives good sound. I have opened both the top and button cover and circuits looks like they are in good condition. But the tape in gives no sound. When set on either the phono or tape...
    Posted to Vintage Products (Forum) by munthe on Tue, Feb 26 2013
    Filed under: beomaster 1900, AUX, failure, vintage, Hum
  • Two defective Beomaster 1900s

    Hi there, first post here! A while ago I have bought myself a Beomaster 1900. Having not tested it myself I found that when it arrived it was, of course, broken (looking at this forum this happens more often :). Originally the left speaker channel didn't work, and most of the lamps were out. Upon...
    Posted to Vintage Products (Forum) by Mkickert on Tue, Feb 26 2013
    Filed under: beomaster 1900, repair, failure, vintage, beomaster., Hum, refurb, broken
  • Beomaster 1900 + Constant hum + Hot

    Hello, What a great forum. I've been reading in the hope of gaining courage to tackle my problem. I have my fathers original Beomaster 1900 amp. Having admired it's beauty since my age could be counted on two hands, I'm very proud to now own such a timeless classic. Unfortunately it can only...
    Posted to Vintage Products (Forum) by markvanloock on Sat, Jun 22 2013
    Filed under: beomaster 1900, vintage, Hum
  • Beomaster 1900-2 tape input low volume

    Hi, I have a Beomaster 1900-2 which is working allright for radio listening. I wanted to use it to listen to music from my iPhone but when I connected the headphone out of my phone to the din5 tape input, the volume is considerably lower than the radio, even with iphone volume almost turned up to the...
    Posted to Vintage Products (Forum) by Wouter on Sun, Nov 17 2013
    Filed under: beomaster 1900, vintage, volume problem
  • Beomaster 1900 i behov av renovering

    Jag har tagit över min fars gamla Beomaster 1900 och behöver komma i kontakt med någon i Stockholmsområdet som kan och vill hjälpa mig att renovera den - mot betalning förstås :) Balance-knappen verkar ha slutat fungera, några av lamporna behöver bytas...
    Posted to Vintage Products (Forum) by nilag on Sun, Jan 12 2014
    Filed under: beomaster 1900, vintage, förstärkare, balance
  • Beomaster 1900 help!!

    Hi all, Just wondering if anyone can help me please I have a lovely beomaster 1900, all of a sudden its having an issue with Preset 4 on fm if you go to lightly tap it it wont work but if you push it really hard it will work. Just wondering if anyone can help me at all? Otherwise the set is working just...
    Posted to Vintage Products (Forum) by Lewis T on Fri, Dec 30 2016
    Filed under: beomaster 1900, repair, help, problem, vintage, amp, amplifier, beomaster, old, Restoration, 1900 humming, 1900
Page 1 of 1 (6 items)
Beoworld Security Certificate

SSL