Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the Vintage Products forum. See all tags in the site
  • Beomaster 1900-2 bad speaker connection

    Greetings people! I am a new and not very tech-savvy member, and i just aquired a beautiful Beomaster 1900-2, in seemingly great condition. However, after hooking it up at home it turns out the speaker connection is quite wobbly and comes and goes, both channels. This is of course very disappointing...
    Posted to Vintage Products (Forum) by Strikecommando on Sat, Apr 11 2015
    Filed under: beomaster 1900-2
  • Re: Beo 1900

    Hi all, I'm new here. Became a vintage B&O lover a year ago when I got a Beogram 4004 my uncle bought at a garage sale for €1. Repaired its mechanics and hooked it up. Delighted by its ideosyncracy both inside and out. Completed the Jacob Jensen set with a Beomaster 1900 and a set Beovox...
    Posted to Vintage Products (Forum) by Mikedutch on Mon, Apr 17 2017
    Filed under: beomaster 1900, Beomaster 2400 goes to standby on off relay clicking caps, beomaster 2400, beomaster 1900-2, balance slider, 1900, B&O Beomaster 2400
  • Beomaster 1900-2 running hot

    Hi, I'm relatively new to the forum as I have a problem with my (recently acquired) Beomaster. I have just finished re-capping the board and as far as I knew, all was running smoothly. Until I felt that the heat sink was running much hotter in one area than the rest of it. Along with this, the left...
    Posted to Vintage Products (Forum) by Gaspar on Wed, Apr 4 2018
    Filed under: repair, beomaster 1900-2
  • Beomaster 1900-2 gradual hum

    Hi all, New to the forum, I've just picked up a beomaster 1900-2 with beovox s35s, Beogram 2202 and a beocord 1900, not a bad haul. Everything seems to be working great, all lights and functions etc. except the beomaster has quite an annoying hum. It's most noticeable at quiet to medium volumes...
    Posted to Vintage Products (Forum) by Sampep on Sun, Mar 18 2018
    Filed under: beomaster 1900-2
  • Beomaster 1900-2

    Hi everyone My Bang & Olufsen Beomaster 1900-2 want to mention you a problem. The first 10-15 minutes after starting to work comes a bottom sound (a buzzing). After 10-15 minutes (perhaps after warming up), this noise from the speakers disappears. Thank you very much Best wishes from warm spring...
    Posted to Vintage Products (Forum) by Memo on Sat, Feb 23 2019
    Filed under: beomaster 1900-2
Page 1 of 1 (5 items)
Beoworld Security Certificate

SSL