Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the General Discussion & Questions forum. See all tags in the site
  • Mixing Beosystem 5000 and 5500 units…

    Hi alls, I own a Beogram CD50 and a Beocord 5000 both working and cosmetically good (and with manuals! ) Even though i didn't like that design/period, I developed a strange feeling about the system and started to look around to complete it, that is and MCP 5000 and a Beomaster 5000. The Beogram is...
    Posted to General Discussion & Questions (Forum) by matador43 on Mon, Sep 7 2020
    Filed under: Beomaster 5500, Beomaster 5000, Beosystem 5500, Beosystem 5000
  • Re: BEOCORD 5000 Type 4922

    Hi Dillen, I have started my Covid lockdown project of renovating my Beo 5000 system. Most of my system seems to still be in working order but the belts (at least those I can see in the Beocord 5000 Type 4922 are a black mush. After reading all the historic posts ( a big thank you to all those who made...
    Posted to General Discussion & Questions (Forum) by Priory99 on Sat, Jul 11 2020
    Filed under: belts, Beosystem 5000, Beocord 5000
  • Beosystem 5000 - which elements from other systems fully works??

    Hello. I am a new forum member and a new Beosystem owner. My "private Beoworld" is Beosystem 5000: - BeoCord 5000 (4921) - BeoGram CD50 (5111) - BeoMaster 5000 (2321) - Master Control Panel 5000 - BeoVox S55 Yes, it's only 5000 but I'm proud of having it, the sound is wonderful ......
    Posted to General Discussion & Questions (Forum) by Martynka on Thu, Aug 9 2018
    Filed under: Beomaster 5000, MCP, beovox s55, Beogram 5000, Beosystem 5000, 5111, MCP 5000, CD50
  • My Beosystem 5000 automatically lowers volume at 40

    So I have a Beosystem 5000 which works mostly great. But recently, it started automatically turning down the volume at 40 - always keeping a steady 38-40 - which is very annoying, as you can imagine when you want to listen to anything remotely loud. At first I thought it was an automatic muting, but...
    Posted to General Discussion & Questions (Forum) by jscottamy on Tue, Aug 15 2017
    Filed under: Volume muting, Beosystem 5000
  • Beovox S-80 woofer problem

    I recently purchased a nice bunch of B&O units that came with a nice pair of Beovox S-80 speakers. I don't know whether the seller had it or I did it while transporting it, but once I finally had a chance to try them out I found that the woofer on one speaker is a bit "punched in"....
    Posted to General Discussion & Questions (Forum) by Jack on Wed, Sep 15 2021
    Filed under: speakers, Beosystem 5000
Page 1 of 1 (5 items)
Beoworld Security Certificate

SSL