Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the Vintage Products forum. See all tags in the site
  • Re: Beomaster 4400 bad noise

    Yes, with the headphone it sounds fine on both channels. I have tried different speakers, cables, mono, stereo, both speaker output (1 and 2). Still no change, the sound from the right speaker output sounds bad. The left one sounds as clear as it should. I carefully opened it just to see if something...
    Posted to Vintage Products (Forum) by DanP on Fri, Apr 27 2012
    Filed under: Beomaster 4400
  • Re: Beomaster 4400 bad noise

    Yes, with the headphone it sounds fine on both channels. I have tried different speakers, cables, mono, stereo, both speaker output (1 and 2). Still no change, the sound from the right speaker output sounds bad. The left one sounds as clear as it should. I carefully opened it just to see if something...
    Posted to Vintage Products (Forum) by DanP on Fri, Apr 27 2012
    Filed under: Beomaster 4400
  • Beomaster 4400 bad noise

    Hi I just received a Beomaster 4400, in nearly “mint” condition. That’s what the seller was claiming. I had it shipped from Germany to Switzerland. After arrival, I, like a kid during Christmas eve full of excitements , unpacked and unwrapped the Beomaster 4400, whaw! It looked as new...
    Posted to Vintage Products (Forum) by DanP on Thu, Apr 26 2012
    Filed under: Beomaster 4400
  • Beomaster 4400 whining

    I wonder if there is anyone out there who can help with a problem that has just arisen on my Beomaster 4400. The fault relates purely to the tuner section. All other inputs (phono, tape, etc) work just fine. When I select any of the tuner buttons the 2 red tuning lights and the strength meter no longer...
    Posted to Vintage Products (Forum) by JontyMaster on Mon, Dec 3 2012
    Filed under: Beomaster 4400
  • Beomaster 4400, only 4,5 ohms between AC plug's two contacts, faulty?

    Hello everyone! This is my first post here in this forum. Previously I had no experience (or never heard of) the brand B&O, until a few hours earlier when I was cruising around the local second-hand shops, I found a B&O Beomaster 4400 unit which seems to be in pretty classy styling and good cosmetic...
    Posted to Vintage Products (Forum) by cctv_1234 on Wed, Dec 12 2012
    Filed under: Beomaster 4400
  • Re: Beomaster 4401 NOT black

    Yes i know, but i have turned it around and on the back it's identical to 4400 but there's a beomaster 3000 powersupply/trafo installed and it's marked with red PP-label (prototype?) will do pictures later tonight after my snookersession ;-).
    Posted to Vintage Products (Forum) by holmolm on Sat, Mar 2 2013
    Filed under: Beomaster 4400, vintage
  • Beomaster 4401 NOT black

    Hi, i came across a Beomaster 4401 with alu-front ! how can this be ? could it be a fraud ? to my best knowledge the 4401 was a black version of 4400. I'm puzzled can anybody inlighten me ? PS i found it on a farm very close to the B&O factory i Struer, think-think.
    Posted to Vintage Products (Forum) by holmolm on Sat, Mar 2 2013
    Filed under: Beomaster 4400, vintage
  • Beomaster 4400 service manual

    Hello, I have to service a Beomaster 4400 and would like before starting, have in hands, the right documents. The one we have on our site is not that nice and I am missing clear pictures of the component layouts. Kindly advise how I could get these. Thanks a lot Alain
    Posted to Vintage Products (Forum) by Traverso on Sat, Dec 13 2014
    Filed under: Beomaster 4400, Service Manual
  • Modern speakers with vintage B&O?

    I'm fairly new to Beoworld and to B&O in general. I have (optimistically) acquired a Beogram 4004 and a 6000, Beomasters 4400 and 6000, and numerous other pieces that I hope to bring back to life. At this point, I have not added any speakers, if only because I have no experience with forty year...
    Posted to Vintage Products (Forum) by Jack on Thu, Sep 14 2017
    Filed under: Beomaster 4400, beogram 4004, speakers, vintage, beomaster 6000 type 2702, 4 channel, beomaster 4000, Beomasterr 4400
  • Re: beomaster4400 poweramp issues

    Hi, While repairing my Beomaster 4400 I found a strange fault. The AFC switch did not work. The switch is soldered to a printed board in the front. The printed board was OK, no cracks, but the connections were dead. Obviously the copper lines on the board were separated from the copper collars around...
    Posted to Vintage Products (Forum) by Omar on Tue, May 1 2018
    Filed under: Beomaster 4400
Page 1 of 2 (11 items) 1 2 Next >
Beoworld Security Certificate

SSL