Sign in   |  Join   |  Help
Click here to change your Beoworld Account Details

Browse Forum Posts by Tags

Showing related tags and posts for the Forums application. See all tags in the site
  • Beogram 8000 vibrating tonearm & general upgrading

    Normal 0 false false false EN-AU X-NONE X-NONE Hello all, I recently upgraded the delaminating tacho disk and all caps on my imported BG8000 (thanks to the replacement packs from Dillen). I now find after the toil that these were not the only issues. When the tonearm slides along the back of the platter...
    Posted to BeoGram (Forum) by CD7000 on Tue, Apr 10 2012
    Filed under: tonearm, problem, Beogram 8000
  • Beogram 8000 transport advice

    Good evening! In the next days or weeks I will have to transport (by car) a Beogram 8000 (or 8002), a Beomaster 8000 and a pair of Beovox MS-150. I am a bit worried about the Beogram... What should I do in order not to damage suspension, tonearm, cartridge and so on? This is not the usual turntable where...
    Posted to BeoGram (Forum) by mscili on Sun, Jul 22 2012
    Filed under: Beogram 8000, transport
  • Beogram 8000: tonearm questions

    Hi everyone again! As part of putting my new B&O devices again in top working order, today I started working on the mechanical part of the Beogram 8000. I successfully cleaned and lubricated again the tonearm carriage (now it moves very quietly and without "effort"), but I have two main...
    Posted to The Workbench (Forum) by mscili on Thu, Aug 30 2012
    Filed under: Beogram 8000
  • Beogram 8002 - tonearm is not progressing inward

    I got my Beogram 8002 back after weeks at the local repairing shop. He fixed the problem (he said) and surely the arm is now lowering at the right place according to what kind of record is on. But after some seconds the arm jumps, and is unable to move inwards. Is it possible for me to fix that? Or is...
    Posted to BeoGram (Forum) by McBryden on Wed, Nov 28 2012
    Filed under: tonearm, Beogram 8000, tangential, 8002
  • Beogram 8000, only speed controls working

    Hi guys, After getting my Beomaster 8000 running again with your help, I thought it would be nice to get the Beogram working as well. The problem I'm having is this: As soon as I plug it in, the TT starts to rotate, displays 33.33. It responds to the speed controls (+,-,45,33), but it does not respond...
    Posted to Vintage Products (Forum) by BeoMaster4 on Mon, Jan 14 2013
    Filed under: beogram 8000
  • Beogram 8000 linear transport carriage behaving badly

    I have recently acquired a Beogram 8000 Type 5613 in very good condition except for the fact that the traversing arm does not work properly. The in PLAY mode, the LED (orange) lights, the arm moves 1 or 2 mm waits a moment, then the LED turns off and arm returns to rest. Platter coasts to stop. In TURN...
    Posted to BeoWorld North America (Forum) by Walt on Sun, Jan 13 2013
    Filed under: beogram 8000, linear tracking
  • Beogram 8000 power transformer module.

    I'm about to embark on my first Beogram restoration (I've restored other reasonably delicate and complex electronic devices over the years but this will be the first TT) I have just bought a non operational Beogram 8000 in great cosmetic condition. I will be sourcing a new tachodisc and capacitors...
    Posted to BeoGram (Forum) by Yuri Pavlinov on Fri, Nov 1 2013
    Filed under: Beogram 8000
  • odd added sound from 8002

    I have a beogram 8002 that plays intermittently. When it plays it produces a sound like a door closing somewhere far off in the house. The sound seems to be fairly regular though I have not timed it. Other than that it sounds great. Could this be the capacitor problem I have read about? Is there a way...
    Posted to BeoGram (Forum) by hultzman on Tue, Feb 25 2014
    Filed under: Beogram 8000
  • Beogram 8000 now working right!

    Hello everyone, I'm happy to share the good news that after recapping my Beogram 8000 is now working flawlessly. The interesting thing is that it was already working fine before, but somehow I always felt that the rotation was not as stable as it should - but at the same time it was not obviously...
    Posted to BeoGram (Forum) by mscili on Fri, Jan 3 2014
    Filed under: Beogram 8000
  • Beogram 8000 - Closed dust cover affects playback

    Hi Beoworld, I'm new to this forum and this is my first post. I tried looking for a similar problem, but didn't have any luck finding any. So here goes. I have a Beogram 8000 (I don't know what the type number is) and I noticed that a closed lid during playback makes some of my records sound...
    Posted to BeoGram (Forum) by Theis on Mon, May 19 2014
    Filed under: tonearm, problem, Beogram 8000, speed, Dust cover
Page 1 of 2 (17 items) 1 2 Next >
Beoworld Security Certificate

SSL