Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the Vintage Products forum. See all tags in the site
  • Beogram 4000 no sound

    Hi, As a preface, I have attempted to search for similar issues here and elsewhere, and didn't find anything. I hate posting questions / help requests when a simple google will suffice! I recently bought a Beogram 4000 in an auction (Sweden) and took it home to find out that I'm not getting any...
    Posted to Vintage Products (Forum) by Asurao on Sat, Dec 8 2018
    Filed under: Beogram 4000
  • Beogram 4000 - what to pay?

    What I was afraid of has happened. Since I bought this old B&O equipment a couple of weeks ago I have decided that I want a top of the line B&O system from the early seventies I have found a Beogram 4000 on an internet auction here in Norway. According to the pictures it looks to be in very good...
    Posted to Vintage Products (Forum) by Airman49 on Fri, Mar 7 2014
    Filed under: Beogram 4000
  • Beogram 4000 tone arm lowering

    Dear forum-members Recently, the tone arm of my Beogram 4000 won't lower anymore: I press start, the tone arm moves to the first track, I hear a click and then nothing happens. I found that some other Beogram 4000 owners also startet a thread for this problem and lubrication should fix the problem...
    Posted to Vintage Products (Forum) by wdermauw on Thu, Nov 8 2012
    Filed under: click, lower, tone arm, Beogram 4000
  • Beogram 4000 - Repairman France

    Hi Beoworld. I purchased, a bit hastily, a Beogram 4000 at an auction. It’s in good aestetic condition but there is probably more repair work on it that I would have hoped for. The belt drive motor runs at 33 and 45 rpm. All external lights seems to be working (Stroboscope, pick up arm, dial, 33...
    Posted to Vintage Products (Forum) by Chaoling on Sat, Jan 22 2022
    Filed under: Beogram 4000
Page 1 of 1 (4 items)
Beoworld Security Certificate

SSL