Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the General Discussion & Questions forum. See all tags in the site
  • Thanks to Dillen

    General shout out to Dillen for supplying belts for my Beogram 5005 and Beocord 5500 - both fixed up a treat in about an hour. Full instructions provided (a double-up of instructions for Beocenter 9500 and Beocord 6500 but in the end it worked out sweet!). The Beocord 5500 is such an easy deck to work...
    Posted to General Discussion & Questions (Forum) by pepps on Tue, Sep 4 2012
    Filed under: Repairs, beogram 5005, happy, Beocord 5500, Dillen, belts
  • Re: Thanks to Dillen

    Hi Martin, While we're on the subject of Beocord 5500's, I have a question: Mine plays back fine, when hooked to a conventional amp. You see the previous owner cut the DIN plug off and wired 2 RCA's to the green and blue leads. I would like to re-install a 7 pin DIN, of which I have one,...
    Posted to General Discussion & Questions (Forum) by georganic on Wed, Sep 26 2012
    Filed under: Beocord 5500
  • complete beosystem 5500 winth penta 1's

    I recently found myself a nice complete beosystem 5500 with active beolab penta 1's. And allthough I have no real complaints, even the opposite, I'm thrilled about them, there are some little issues. Allthough the speakers play perfectly I find it a pitty that I only had one 4 pin DIN speaker...
    Posted to General Discussion & Questions (Forum) by cee on Mon, Jul 20 2015
    Filed under: Beomaster 5500, beolab penta, Beocord 5500, active speakers, Beogram 5500 record player, MCP 5500, B&O 5500 System, 5500, Beosystem 5500
  • Beocord 5500 Display Problem

    Hi All, My Beocord 5500 display doesn't show the signal level on the LED 'VU meter' when recording or playing. The 'VU meter' within the remote controller works just fine though. Does anyone have any idea what the cause could be or could recommend a repair agent near Surrey (UK)....
    Posted to General Discussion & Questions (Forum) by rbulkley on Fri, Jul 10 2015
    Filed under: Beocord 5500
  • Re: Beomaster 5500 Intermittent Noise at Certain Volume Levels

    Beomaster 5500 Issue Resolved: I took Nick's advice and using my Sencore LC77 Auto-Z Capacitor - Inductor Analyzer, removed and tested every electrolytic in the Beomaster 5500. As expected there were several bad electrolytic caps on the Output Amp & Power Supply board...11 of the small caps had...
    Posted to General Discussion & Questions (Forum) by TrackerJack on Tue, Feb 26 2019
    Filed under: Beomaster 5500, Beocord 5500, Beolab Penta mk1 mk2 mk3, Beomaster 5500 system, Becord 5500
  • Re: Thanks to Dillen

    Thanks for that, Beobuddy, now I just need a schematic to tell which wires are what color...
    Posted to General Discussion & Questions (Forum) by georganic on Thu, Sep 27 2012
    Filed under: Beocord 5500
Page 1 of 1 (6 items)
Beoworld Security Certificate

SSL