Sign in   |  Join   |  Help

Browse Forum Posts by Tags

Showing related tags and posts for the The Workbench forum. See all tags in the site
  • BeoSystem3 not communicating with BeoVision4

    Hi, My problem s that I am not able to switch on TV and don't know if I have a fault or not. I have hooked up the Beosystem 3 to a Beovision 4 65" Plamsa (by Panasonic). When powering up the Beosystem, a green LED on the Beosystem is on for a couple of seconds and then switched OFF again. At...
    Posted to The Workbench (Forum) by alltvrepairs on Sat, Jan 19 2013
    Filed under: voltage, wiring, Beo4, Beocenter, photodiode, photocell, Repair
  • Beocenter 2800 - cant stop platter on record deck spinning

    Hi Everyone, Just wondering if anyone can help me, yesterday I got myself a Beocenter for a bargin! only £40 I have plugged it in and connected it to my Beovox s35-2's and I must say it sounds great. It is fully working apart from the odd sticky stitch what I believe is common and the issue...
    Posted to The Workbench (Forum) by Lewis T on Wed, Jan 1 2014
    Filed under: wiring, Beocenter, Vintage Beomaster, tonearm, beogram, Repair, amplifiers, power switch, on/off switch, fix, rebuild, turntable, vinyl, vintage
  • Beocenter 7000 heating and shutting off issue

    Hello all, hope you're well today. Story : I purchased a Beocenter 7000 (type 1801) from a genlteman that had recently retired and was planning on leaving the country. He had purchased it back in '79-'80 and has had it stored away for almost 20 years if not more. I have been using an old...
    Posted to The Workbench (Forum) by CrabbyHermit on Mon, Feb 8 2016
    Filed under: Beocenter, Repair, vintage, Opamp, overheating, output, Beocenter 7000
Page 1 of 1 (3 items)
Beoworld Security Certificate

SSL