Sign in   |  Join   |  Help
All Tags » Becenter (RSS)

Browse Forum Posts by Tags

Showing related tags and posts for the The Workbench forum. See all tags in the site
  • Beocenter 7002 - Amplifier problem

    Hi all I have some problems repairing my Beocenter 7002 amplifier; main fuses burned. One channel is good, the other needs the replacement of IC200/Ic201 and 0,36 ohm resistor. With this solution the IC began to be hot at 2 volts (2 of 30V); so replaced all the transistors and diode (step by step). Actually...
    Posted to The Workbench (Forum) by Eugenio on Fri, Jan 18 2013
    Filed under: amplifiers, Becenter, fuses
  • Beocenter 1 Distorted Picture

    Hi beo guys and gals I have recently been given a BC1 with the following problem. The set starts up with a beautiful sound & picture on either stb or the built in DVD, however on any picture input it has a pinching in of the picture at the top and bottom both sides eg slight horizontal symmetrical...
    Posted to The Workbench (Forum) by Maurice on Mon, Aug 26 2013
    Filed under: Becenter
  • Beocenter 2200 tuning

    Hi all Can anyone help with a problem i have with this item, the FM radio now works after much cleaning of the PRESETS 1234 on all four of them. however if the set is switched off for a period of time anywhere over 2 hrs the presets have to be retuned to pick up a station again .FM manual tuning on the...
    Posted to The Workbench (Forum) by Maurice on Tue, Sep 10 2013
    Filed under: Becenter
  • Beocenter 9500 cutting out

    Hi all Recently I have been refurbishing a BC9500 in beautiful condition, I have reattached the glass panels and fitted a new micro computer 3volt battery as CODE was displayed in top RH . this was done with a beo4 remote, during testing a fault was evident on the BALLANCE Function, the unit would start...
    Posted to The Workbench (Forum) by Maurice on Thu, Feb 6 2014
    Filed under: Becenter
  • DEADLY ! Beocenter 3500

    Recently my local B&O store showered my with gifts as is there way from time to time! This gift was a beocenter 3500 I was advised that it wouldn't power up the first thing I checked was the mains plug fuse that was ok . Trying the system it did once power on but I get a static discharge when...
    Posted to The Workbench (Forum) by Maurice on Tue, Jun 17 2014
    Filed under: Becenter
Page 1 of 1 (5 items)
Beoworld Security Certificate

SSL