Sign in   |  Join   |  Help
All Tags » 4000 (RSS)

Browse Forum Posts by Tags

Showing related tags and posts for the Vintage Products forum. See all tags in the site
  • Beocenter 4000 type 1603 output stage voltage

    Hi All, Just wondering if anyone can help at all, I am in the process of restoring a Beocenter 4000 type 1603. I have recapped the amps and psu with new caps and its been reccomended I change the pots on the output stages I have some on order but I cannot seem to find on my circuit drawings what the...
    Posted to Vintage Products (Forum) by Lewis T on Thu, Jan 25 2018
    Filed under: speaker sets, repair, help, Beocenter, vintage, noise, becenter, refurb, Classic Audio, speaker channel, DIN, cover, amp, amplifier, beocenter 4000, old, 4000, Service Manual, how to, potentiometer, Hifi, channel lost, repair., output
  • Beomaster 4000 radio problem

    I had some Beovox S60 speakers for a while that i bought for £35 and recently i bought a Beomaster 4000 as faulty to go with them. The problem with the Beomaster 4000 is that the radio function doesnt work, it just sounds like static and none of the presets or the slider change it. i had a quick...
    Posted to Vintage Products (Forum) by aristomuy on Tue, Nov 1 2016
    Filed under: Beovox S60, beomaster 4000, 4000, bm4000
  • Beocenter 4000 type 1603 - powerup noise help

    Hi Everyone, Just wanted to ask if anyone knows what might be happening with my Beocenter 4000 the 70's version. I brought it cheap from the internet, it arrived and was working 100% fine for a few days but over the weekend I plugged it in and switched it on but when you now switch it on from a cold...
    Posted to Vintage Products (Forum) by Lewis T on Mon, Jan 13 2014
    Filed under: repair, help, Beocenter, vintage, old, 4000, buzzing
Page 1 of 1 (3 items)
Beoworld Security Certificate

SSL