Sign in   |  Join   |  Help

Beogram 8000 IR led, intermittent and manual controls failures

rated by 0 users
Not Answered This post has 0 verified answers | 1 Reply | 1 Follower

hamacbleu
Top 500 Contributor
Québec, Canada
194 Posts
OFFLINE
Bronze Member
hamacbleu posted on Mon, Sep 2 2013 3:20 AM

Here's my last beogram 8000 adventure, just in case that the solutions would be useful to somebody, somedays..

A few weeks ago, the "rewind" and "fast forwarding" control of my beogram just stopped working. I did have a replacement capacitors kit that I got from Dillen last year, but I never used it, since the turntable never really showed any faulty signs. (I'm more of a type "if it works don't touch it") Here was a good occasion to finally change the lot.

However, after the recap, the same problem remained, plus an intermittent failure in the lamp on the front of the detector arm. Also, in the learning process, I created more harm than good: playing with probes and continuity, I made sparks appeared near a connector on P2. Then, when that was solved, the arm would drop even when there was no record (glad I kept an old broken stylus for testing purposes: the sound it made was horrible)

Here's the solutions in the order I solved them:

 

1. Carriage that goes forward forever

After the sparks appeared, when play was pressed, the tone arm would move infinitely forward without any stop. Not really good for the belt.. and the carriage.

I knew that the sparks led to a component called OPE1. Its a small device placed above the motor that emit a IR light to 2 phototransistors. 

From what I understand, when the screw carrying the carriage is turning, a small round plastic piece is blocking and unblocking that IR light to the 2 photo transistors above. Depending on the order that these 2 transistors sees the light or not, the microprocessor knows exactly where the carriage is. The same technology seems to be used for the tachosensor and for the volume control of the Beomaster 8000..(I think it's cool for an early 80's thing!). 

Anyway, some tests revealed that I destroyed that IR led. Here's a clear photo of that OPE1 and of the led:

Of course, Martin had the replacement part and kindly offered it to me. 1st problem solved.

 

2. Arm dropping even when there was no record

I was guilty on that one too… Martin told me that the light from the detector arm has to make a perfect round spot on the platter, at the right place, and that the position of the bulb and the orientation of the filament in the detector arm was critical… When I was messing around trying to solve the 1st problem, I removed the screw of that detector arm showed in the picture below

When I put it back, it was to tight, making the detector arm pointing slightly upward.I just adjusted that screw so that the detector arm was perfectly parallel with the platter and Voilà…

 

3. Intermittent failure of the bulb inside the detector arm

That one was annoying. During that failure, the carriage would behave like in the 1st problem, then It would have to be rewinded manually to put it back into it's starting position. (patience required). However, that problem was only happening when the chassis was put down.. not in service mode. A bad connection somewhere. a magnifying glass revealed a cracked solder joint on a connector of P2…

(By the way I've found out that a few others would have soon become problematic, especially in the area of the transformer connectors. I reflowed every one of them)

 

4. Manual rewind and fastforward not working

After all this, and looking at the schematics for hours, I began to understand a little more about some technical features of this turntable. Inside the operating panel, there is a 0,3mA 18V bulb that shines on 2 photo resistors:

When one of the button is pressed (on the back of that board), a blind is removed from those resistor and depending if it's partially or totally removed, the light shines more or less on them, allowing a variation of the speed of the moving carriage.. clever.

Anyway, that said bulb was just dead… that part seems to be hard to find. Without surprise, however, Martin had them..

So my beogram is now like new, fully recapped and functional. I really hope it will last for a long time. All these new caps will surely help… A huge thanks to Martin for is precious advices and fast shipment..

And by the way just a few warnings:

1. Don't start the turntable without the subplatter: not good. It will blow the fuse in the transformer module… (yes I did)

2. Don't try to clean your platter with rubbing alcohol…it removes the coating on it and makes some shiny spots. I think it's best to leave it has it is (yes I did but the damage were minimal, fortunately)

I think i'm now ready to get back to my beocord 8002. It's been almost a year that it's sole function is to decorate… However, I now might have a good idea of what's going wrong with it. So I'll be back soon

Guillaume

All Replies

ALF
Top 100 Contributor
AUS
890 Posts
OFFLINE
Silver Member
ALF replied on Sat, Jul 9 2016 10:56 AM

Hello hamacbleu,

Great post and inspiration for me - I had a non-working manual forward/reverse issue and suspected

A processor fault, however it was that famous light bulb !!!!!

I settled for a 24V one I happen to have.......and it worked:-):-):-):-)

Nice when you learn something as I wasn't aware there's a light bulb involved. 

Many many thanks !!

Cheers - ALF

Page 1 of 1 (2 items) | RSS
Beoworld Security Certificate

SSL