Sign in   |  Join   |  Help

Beolab 4000 speakers

rated by 0 users
Not Answered This post has 0 verified answers | 3 Replies | 1 Follower

sta38
Not Ranked
2 Posts
OFFLINE
Bronze Member
sta38 posted on Sun, Aug 18 2013 11:22 PM

Hi, I've been given a Beocenter 2300 system and a pair of Beolab 4000 speakers the system works absolutely fine however there is one small problem in that one of the speakers randomly gets power to it whilst the main unit is turned off, the power light on the speaker will flash and click and this will continue till I turn the main unit on - the system then works absolutely fine until I put it back into standby mode and the problem with the speaker starts again, I have had the system approximately 6 months and this has only started in the last few days. Any ideas/help gratefully received, unplugging the system from the mains each night is not an option as mains plug not easily accessible. Thank you   

All Replies

MediaBobNY
Top 75 Contributor
Greenwich Village, NYC
1,106 Posts
OFFLINE
Bronze Member

Assuming you have the older version BL 4000's, the power light on the speaker is also an on/off switch.  Power it off.

sta38
Not Ranked
2 Posts
OFFLINE
Bronze Member
sta38 replied on Sun, Aug 18 2013 11:40 PM

Thank you, yes i have the older version, at least now i can turn them off at night - would still like to know what is causing the speaker to get power to it don't want to damage them

Søren Mexico
Top 10 Contributor
Mexico City
6,384 Posts
OFFLINE
Bronze Member

Shift the speaker connection left to right, if the failure is still in the same speaker, you have a speaker problem, if not cable or amp problem

Collecting Vintage B&O is not a hobby, its a lifestyle.

Page 1 of 1 (4 items) | RSS
Beoworld Security Certificate

SSL