Sign in   |  Join   |  Help

Beogram 8000 Set-down Not Working Properly

rated by 0 users
Not Answered This post has 0 verified answers | 3 Replies | 1 Follower

John Francis
Top 500 Contributor
USA
152 Posts
OFFLINE
Bronze Member
John Francis posted on Wed, Nov 24 2021 11:12 PM

Hello All,

I have been doing a little routine maintenance on my Beogram 8000 which included lubricating the rails, cleaning and putting a recently restored dust cover back on. I notice while doing this that the detector arm and pick-up arm although parallel to each other, were not at a right angle to the rails. I adjusted both arms to correct for that. Now when I try to play a record the pick-up arm starts to drop where it looks like it should, but just before it reaches the record it moves inward toward the spindle a short distance, so does not play the beginning of the record. I tried adjusting the SO switch but that did not fix the problem. I did notice the plastic cover for the two arms binds a little so took that off to see if that might be the problem, but that wasn't it. Does this seem like a mechanical issue or an electronic one? The turntable was working fine before my arm adjustments.

Any thoughts appreciated!

John

All Replies

John Francis
Top 500 Contributor
USA
152 Posts
OFFLINE
Bronze Member

It occurred to me that I should check to see if I moved the tonearm further into the record and see if I pressed play the tonearm still moves inward just before it sets down, it does.

Mark
Not Ranked
San Francisco
53 Posts
OFFLINE
Bronze Member
Mark replied on Thu, Nov 25 2021 10:33 PM

You need to go through the arm tangential tracking adjustment (Aperture and Photo Control) that is detailed in the Service Manual.

John Francis
Top 500 Contributor
USA
152 Posts
OFFLINE
Bronze Member

Thanks, Mark! I will take a look at that today in the service manual.

John

 

 

Page 1 of 1 (4 items) | RSS
Beoworld Security Certificate

SSL